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Foreword 

The Expert Series 12.0: Tutorial 1 - Working with 3D Models document provides 
an introduction to the basic 3D model handling with Expert Series software 
products: 3D model viewing, measuring, repair, splitting, connecting, adding lap 
joint, hollowing, drain hole generation, Boolean operations, support generation, 
surface triangulation, data reduction and separating shells for different material or 
color definitions in one part.  

Expert Series 12.0 is available as a 64 bit implementation allowing you to handle 
huge models for Additive Manufacturing.  

Full tutorial set for Expert Series contains several documents which cover 
different aspects of model repair, coloring and print preparation. The tutorials are 
available in the software distribution package through the Help > Tutorial 
Documents menu:  

 Expert Series 12.1: Quick Start Guide gives a short introduction to model 
repair and splitting for 3D Printing with 3Data Expert, 3Data Expert Lite 
and Dimensions Expert products. Estimated completion time 15 minutes. 

 Expert Series 12.1: Tutorial 1 – Working with 3D Models introduces basic 
viewing, measuring, automatic repair, split, connect, hollow, offset, 3D 
Text, Boolean, cut, reduce, 3D nesting, surface triangulation and other 
model manipulation functions available for STL files. Applies to All Expert 
Series modules. Estimated completion time is 3 hours.  

 3Data Expert 12.1: Tutorial 2 – Working with Colors introduces basic 
automatic repair and coloring for 3D Color Printer users. For 3Data Expert, 
3Data Expert Lite and 3DEdit Pro. Estimated completion time is 1 hour.  

 3Data Expert 12.1: Tutorial 3 – Separating Shells describes the use of 
Shell Separation commands in 3Data Expert. These commands enable 
separating a part into several shells for different material (shore value) or 
color definitions in a single part. For 3Data Expert only. Estimated 
completion time is 30 minutes.  

 3Data Expert 12.1: Tutorial 4 – Generating Supports for AM explains the 
use of new Generic Supports command and Sand Supports command. 
The support generator can be used to generate supports for DLP, metal, 
stereolithography and sand based processes. Adding extra connectors to 
prevent parts from warping and bending during the build is explained. 
Also, new slicing, slice preview and slice filling is demonstrated. Estimated 
completion time 1 hour.  

 Expert Series 12.1: STL and VRML repair examples document includes 
more advanced model repair operations with 3Data Expert. Applies to 
3Data Expert module and mostly to 3Data Expert Lite, Dimensions Expert 
and Sim Expert modules. Estimated completion time with 3Data Expert 2 
hours.  
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The tutorial documents and the geometry files for the tutorial examples are found 
in the Tutorials folder and its sub-folders (GeomFiles, Tutorial 1, Tutorial 2, etc.) 
in the 3Data Expert (or product in question) installation directory.  

Additional information and help on other STL manipulation tools can be found in 
the Handling Faceted Files section of the On-line Help pages. These pages 
contain information on verifying, repairing, splitting, offsetting, hollowing and draft 
checking for tooling applications.  

The operations given in boldface in this document are commands which affect 
the geometry of the part in question or are otherwise important and must be run 
by the user in the given order to get the results show in this document. Several 
other commands, like viewing and clipping, are not given in boldface but should 
be used to be able to generate a correct result. Terms given in italics refer to file 
names, commands, shell names, surface names and parameters for different 
commands.  

Modules 

The lessons in this tutorial are organized in such a way that that the required 
software functions increase along the lessons. The lessons can be started with 
View Expert, continued with Dimensions Expert or 3Data Expert Lite and finally 
requiring 3Data Expert to complete the last two lessons (or Sim Expert, 
specializing for simulation applications). Of course, it is best to use 3Data Expert 
from the first lesson, if available.  

DeskArtes Expert Series software suite consists of several products targeted 
from home and DIY use to education and professional Additive Manufacturing: 

 Free View Expert is entry level tool targeted for viewing, verifying, 
repairing, dimensioning and communicating 3D geometry information. 
Free View Expert allows you to input triangle models, create consistent 
topology, check errors, orient normal, repair gaps and self-intersections, 
edit triangles and output STL data for 3D printing without any cost. 

 AM Expert module (option to Free View Expert and 3Data Expert) 
provides automatic AM process selection based on part requirements 
(material, size, accuracy, tensile strength and post processing). AM Expert 
database currently includes 129 professional AM systems and is regularly 
updated.  

 Dimensions Expert is a simple, economical and user friendly tool for STL 
repair and 3D model splitting for machines with a smaller build area. Tools 
include Repair, Splitting and Connect with Pins or Lap Joint.  

 3Data Expert Lite includes all standard 3D model preparation tools for 3D 
Printing and Additive Manufacturing. Available tools include geometry 
generation, Boolean and 3D markup commands, Offset, Hollowing, 
Coloring and Texturing, Solidify (aka “shrink wrap”) as well as Slicing and 
Tool compensation. Optional 3D Nesting makes 3Data Expert Lite a 
perfect 3D data preparation tool for powder based AM systems.  



Expert Series 12.1: Tutorial 1 – Working with 3D Models  

 Page 7 

 3Data Expert is professional tool for preparing 3D models for Additive 
Manufacturing and Simulation applications. There are several commands 
for manipulation of both 3D surface models and 3D faceted models. These 
commands include Surface triangulation, STL verification and repair, STL 
Offsetting, Splitting, Connecting, Decimation, Smoothing, Solidify, 
Boolean, Part subdivision, 3D Nesting, Z Compensation, Slicing and Tool 
Compensation as well as STL Coloring and Texturing. Supports can be 
generated for DLP, metal and stereolithography processes. Special Sand 
Support command creates supporting plates for delicate sand parts with a 
push of a button.  

 Sim Expert is a dedicated tool for preparing 3D models for Simulation 
applications, with triangle count reduction and triangle aspect ratio 
improvement functions. 
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Lesson 1 – Basics User Interface properties 

This lesson shows you how to do basic file input, viewing, dimensioning and 
verification of surface data with the Expert Series. This lesson can be performed 
with View Expert, Dimensions Expert, 3Data Expert Lite, 3Data Expert or Sim 
Expert  module.  

Green box indicates if the lesson is applicable to the given module. 

 Free View   Dimensions  Lite  3Data  Sim 

 

You will need a license to go through the lessons except the ones marked with 
Free View (Expert). Before starting the lessons please make sure you have 
received and installed the software evaluation license from DeskArtes. If you do 
not have a license yet, it is very simple to request a license. First start the 
DeskArtes 3Data Expert (or Dimensions Expert, etc.) by clicking on the icon 
created on the desktop during the installation.  

 

Then go to the Program licenses dialog through Help > Licenses command. 
There you can find the Request evaluation license on-line button.  
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Press it and it will open the DeskArtes license request page on your favorite web 
browser. Fill in the required fields and press Submit evaluation request button to 
send the license request to DeskArtes. 

 

You will receive the 15-day evaluation license within 24 hours.  

When the license  arrives, press Install license code button and Copy/Paste the 
license string into the input field that appears: 

 

Then press OK as requested to accept the license. Finally, restart the software. 
Now you are ready to go ahead with the lessons! 

If you wish to install network licenses please have a look at the On-line Help 
(Help > Help Topics command) page Installation / Licenses section. 

If you have used the Expert Series 12.0 earlier in your computer you may want to 
delete the settings files (settings3DE120das, settignsDIME120.das, … 
depending on the application in use) in the user home directory and then restart 
the program. This initializes the system into its basic state and ensures that your 
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results will not differ from the lesson results. Please see the On-line Help 
Installation / Settings page for the location for settings file for each Expert Series 
software. 

Free View Expert 

Free View Expert functionality does not require a license. With Free View Expert 
you can input several faceted file formats (STL, PLY, ZPR, VRML, …), create 
topology for the model, check errors, repair 3D models automatically and 
manually as well as output the checked data for 3D Printing (STL, VRML, PLY, 
ZPR). Or you can communicate the errors with the other Free View Expert users 
or users of other Expert Series modules, like 3Data Expert. For more serious 
repair work and model manipulation, like split, connect, hollow, drain hole, 
support etc. with other Expert Series modules a license is required.  

Sandbox mode exceptions 

Some Expert Series functions, like Drain Hole and Hatch Supports, are created 
using a separate background process started from Expert Series. In this case 
some antivirus software products may try to restrict the background process 
executable into “Sandbox” mode. This will cause the command to fail. To fix the 
problem set an exception for the background process executable. This is 
normally done through the antivirus software interface where you can change the 
run mode from “Sandbox” to “Normal”.  

 

File input 

In the sequel we will use 3Data Expert as the example program. For other 
modules, like Dimensions Expert, the file paths are identical except for the 
module name, where 3Data Expert is replaced with Dimensions Expert, for 
example.  

You can start the DeskArtes 3Data Expert by clicking on the icon created on the 
desktop during the installation. If no desktop icon is created, use Start menu to 
search and launch the software.  

 

After starting the system and closing the Message dialogs you will see the basic 
configuration of the 3Data Expert on your screen including menus, different 
toolbars and the display area. The menu selection varies depending on the 
Expert Series software in use.  
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The file input is normally done through standard Microsoft File Open dialog with 
File > Open command.  

 Start the File > Open and select the Tutorials / GeomFiles folder 
under the software installation directory. 

Commands given in boldface must be run to get the desired result for the 
lesson.  

The file type is chosen from the Files of type dropdown list.  

 Select type STL files (*.stl) and you will see the list of STL files in the 
GeomFiles directory. 

 Select slubox-gap.stl from the file list and press the Open button.  
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After a while you should see the slubox geometry on your screen, as seen on the 
next page.  

When a model is inputted 3Data Expert allows to check and set the units to the 
part. For example, STL files do not have any unit information in them. Possible 
choices are Inches, Millimeters, Centimeters and Meters.  

 - Press OK to accept the proposed units millimeters (mm).  
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Next you will be prompted for the Operation Mode. 3Data Expert has four main 
operation modes: Fix Model, Paint & Texture Model, Print Preparation, and View 
Model mode. You may have different set of Modes available depending which 
module you are running. The different modes are used for different tasks: 

 Fix Model takes you to automatic model verification and repair, and 
contains shortcuts to the main tools used for repair work;  

 Paint & Texture Model displays the tools for painting and texture image 
addition. This mode also checks the model for errors when selected and 
sets the display into “what you see is what you get” display color mode. 
Note: this mode is only available with 3Data Expert;  

 Print Preparation shows tools for model manipulation, such as hollowing 
and splitting. This mode also checks the model for errors when selected. 
Note: this mode is not available in Sim Expert;  

 View Mode allows you to temporarily view the model and then return to 
Operation Mode selection later (or to close the minimized window).  

 

 

 

The normal way to begin repairing a model is to start with the Fix Model mode. 
To start fixing  

 press the Fix Model button (in red circle above) in the Operation 
Mode dialog now. 

3Data Expert will begin automatic model verification (Fix Model > Verify Shells 
command). The screen is erased and a progress bar appears. When the analysis 
is ready, Auto Repair dialog with Model status message is displayed 
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You will also see the model structure in the Model Tree on the left-hand side of 
the graphics area (see the image below). The model is divided into separate 
shells during verification. In this case we only get one shell (1. slubox-gap 
(Verified)). The shell has errors (i.e. gaps), which is indicated by the    red icon       
in the Model Tree (correct shells would have green icons     , non-verified with 
yellow icons    ) .  

The Model status message indicates that there is one verified shell, which 
contains errors. The display shows red Gap curves through the surfaces. You 
can use the viewing commands when the Auto Repair dialog is visible, zoom 
(mouse wheel) and pan (Ctrl + left mouse button) if you cannot see the gap.  

On the right hand side of the graphics area you will see the Tools Window. Fix 
Model Tab on the Tools Window provides shortcuts to the commands available 
for repair, like Repair Shells, Offset, and Fill Gaps commands. The Help text 
window at the lower part of the Tools Window also contains information for 
required repair actions.   

Auto Repair is normally the best path to follow when repairing 3D models. The 
different parameters for Auto Repair are set automatically, you normally should 
accept them as they are. Later we will see examples where the automatically set 
parameter values are changed. Anyhow, this time we are not going for full repair 
immediately (this is done in the Quick Start Guide), instead we will now 
investigate the Model Tree, Tools Window and selection mechanisms available in 
the software.  

So  

 - press the No button (in red circle above) to start viewing the model now.  

A status window appears: 
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 Press OK to continue to see the Tip Window with useful tips on 
viewing and selection mechanisms. 

 

 After reading the tip you can Close the window. You may also prevent 
it displaying in the future by ticking Off Show Command Tips setting.  

 

After closing the Tip Window you will see the model on the graphics area: 
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The model icon is red to indicate that it has errors (gaps). The different colors of 
the object (pink and blue) on the graphics area are caused by the gap. Through 
the gap we can see inside the part. The outside (normal side) of the surfaces is 
displayed with pink color and the inside (inverted normal side) is displayed with 
blue color in the default Repair color mode.  

 

Model Tree 

On the left hand side of the 3Data Expert window you can see the Model Tree. 

 

This window shows you the current 
contents of the program database. With 
this file you can see one shell, 1. 
slubox-gap (Verified). The shell icon is 
red indicating errors in the model. The 
(Verified) text indicates the last 
command run on the model. 

 

 

 

At the bottom of the Model Tree you 
will see the number of Shells, Surfaces 
and Triangles in the model as well as 
the extents along different axis. We will 
later take a more careful look at the 
contents of the Model Tree. 
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You can press F8 to open and close the Model Tree window.  

 

Basic viewing commands 

Try the following commands to become familiar with viewing operations. Note 
that the commands below do not alter the model’s true 3D coordinates. They only 
alter the eye-point location:  

 Rotate the model on the screen by pressing the middle mouse (MMB) and 
moving the cursor. MMB rotation is always available. Left mouse button 
(LMB) rotation is available most of the time except when working with 
painting, texturing, curve editing, and transformations (LBM is mostly used 
for selecting objects as shown later).   

 Rotate the model around a selected surface point by pressing the right 
mouse button (RMB) and moving the cursor. A blue cross indicating the 
rotation middle point appears on the part surface if the cursor is on top of 
the model when the RMB is pressed.  

 Pan the model by dragging with the Shift + MMB (or LMB most of the 
time) (Shift + MMB means pressing the Shift key and dragging with the 
mouse). 

 Pan with rubberband by dragging with Shift + RMB. 

 Zoom in/out by rotating the mouse wheel. 

 Zoom in/out with Ctrl + MMB (or LMB).  

 Zoom to box with Ctrl + RMB.  

 Hide all by pressing the       icon with LMB (or F5) 

 Show all by pressing the        icon with LMB (or F6) 

 Fit the model by pressing the       icon with LMB (or F7). 

 

The main viewing command icons reside in the Viewing Toolbar: 

 

 

 

Try them out now. The tooltips provide a short description of each icon. Let the 
cursor remain on top of the icon for a couple of seconds to see the tooltip: 
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Also, the Viewing Planes x/y/z toolbar above allows you to select any projection 
direction as the viewing direction with LMB. 

 

 

 

You can show the green selection box around the selected object by pressing the 
Show Bounding box icon in the Viewing Toolbar: 

 

 

Try also Clipping functionality 
through the Clipping Tab to look inside 
the model. The Clipping Tab is opened 

with the      icon. The clipped area 
can be displayed with different ways, 
like with wireframe or transparent.  

Clipping also enables to extract real 
time slice information from the model. 
Real time slices can be copied to the 
Model Tree for internal model 
dimensioning with the Edit > Save Clip 
curves command.  
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Selecting objects 

The object selection can be done either from the display area or from the Model 
Tree. Erase the screen and then display the object node 1. slubox-gap 
(Verified) again by clicking it in the Model Tree. Now we have done one 
selection at the shell level. This level can also be called as the part or component 
level, depending on the context. Click on the little box with the '+' icon besides 
the part name. The result should look like below: 

 

 

The node 1. slubox-gap (Verified) has 
opened and shows the contents of the shell. 
Each shell (1. slubox-gap (Verified)), consists 
of several leaves, surfaces (1. Verified, ...), 
which all together make up the whole slider. 
Triangle surfaces are  identified with the        
icon    . STL model is subdivided into 
separate surfaces along sharp edges during 
the Verify operation done earlier.  

 

Select surface number 3 from the model tree by clicking it with the left mouse 
button (LMB). You can see one of the surfaces displayed with a green Bounding 
Box around it. Now this surface is your current selection (make sure the 

bounding box display is set through         icon.  

The selected surface is also highlighted on the screen. The surface number 3: 

 

The model contains errors, one gap. The gap data is also located in the Model 
Tree after the surfaces (please see next image). Similarly, gaps can be selected 
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from the Model Tree for different operations, like Fill Gap command (to be done 
later).  

 

 

Selecting shells, surfaces and triangles graphically 

You can also select shells or surfaces from the display area by pointing with the 
left mouse button (LMB). First  

 display the Tools Window by pressing Shift+F8 (if not already 
visible): 

 

The Tools Window includes shortcuts to 
frequently used repair, coloring and print 
preparation tools as well as Help text to 
aid with the repair work. You will later 
learn more about the use of the Tools 
Window.  

In the sequel we will use the Selection 
mode buttons to set the Selection Mode to 
correct level.  

Note: The Tools Window is not available with 
View Expert software, you should use 
appropriate Edit > Selection Mode command 
from the Edit menu to set the correct Selection 
mode. The default selection mode is Shell. 

You can use Shift + F8 to open and close 
the Tools Window. 
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During model repair, you can select target objects (whole model, individual shells 
or surfaces, triangles and gaps) to work on from the display area. The selection 
is done with the left mouse button (LMB), and the selection target is controlled by 
the Selection mode buttons in the Tools Window:  

 

The four Selection mode buttons refer to selecting the whole model, one shell, 
one surface, or one gap/triangle, respectively. Now try to select a shell from the 
display area, such as the 1. slider (IGES Input). The Selection mode is on Shell 
selection by default but if not press the 

 

button to turn on Shell selection. Then click with the LMB on the model and 
the shell is selected. Then set the Selection Mode to Surfaces with 

 

and click with LMB on surface 3 which now gets selected. If you wish to select 
objects behind surface 3 just re-click with LMB without moving the mouse. 

Then press the  

 

button to turn on the Gap selection and click close to the gap on the graphics 
area to have it selected in the Model Tree. 

Note: Triangle selection mode available through the Paint and Texture tab are reserved for 
painting the model, please see “Tutorial 2 – Working with Colors” for more information. 
Otherwise triangles are selected and manipulated through Fix Model > Edit Triangles 
command.  

Multiple-selection can be done by pressing the Ctrl key down while selecting 
objects from the graphical area or from the Model Tree with the LMB. The Shift 
key can be used to select objects between the first selection and the latest 
selection in the Model Tree. Different combinations Alt, Shift, Ctrl + LMB on the 
graphics area create, add and delete objects from the multi-selection, please see 
Online Help page Selection / Selecting objects. Multiple-selection can be used 
with several commands, like Transformation or Fix Model menu commands.  

 

Display Area menu 

The right mouse button (RMB) has a special meaning on the display area.  
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 Press the Surface selection mode button again. 

 

 Clicking the RMB now on top of a displayed object brings up the 
Display Area Menu (not available in Triangle/Gap selection mode): 

 

When you click the RMB on the model 
while in the Surface selection mode the 
surface which is nearest to the cursor is 
indicated on the first menu item.  

 Click RMB on top of surface 3 
again. 

 With the Next/Previous command 
you can indicate surfaces which are 
behind surface 3 along the line of 
sight at the mouse position.  

You can also change the shading and 
visibility of the selected object with the 
commands in the menu. If you wish to 
select the indicated surface, press Select. 

 

The 1487: OK triangle entry in the RMB menu indicates the input number of the 
triangle below the cursor. If this menu item is selected, more information about 
the triangle is displayed. This can be helpful especially when working with 
triangles with errors.  

If other Selection mode, like Shell selection is in use, the RMB menu on graphics 
is shorter and gives as the first item the name of the shell at the mouse location.  

Similar popup menu is also available on the Model Tree with the RMB click, 
please try that too.  
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Object properties 

Information about the properties of the currently selected object is given to the 
user in two different ways.  

 

The basic information about the current 
selection is given below the Model Tree 
window. Here we have a shell level 
selection, with some surfaces and 
triangles.  

 

There are three places to display the 
Selected Object Properties:  

 The menu command View > 
Object Properties or  

 the Model Tree RMB popup 
menu command Properties item  

 or the Display Area popup Menu 
Properties  

Properties menu item opens a dialog 
with more accurate information of the 
selected part in the Model Tree. 

  

The exact position of the part is given as bounding box values in the Selected 
Object Properties window. Also, the extents, volume and the surface area of the 
object is calculated.  

Note: with this example the Volume is may not be correct. This is due to the fact that the 
model is not solid. The Volume is reliable with Repaired faceted models without gaps and for 
surface models with consistently oriented surface normal. The Area value is always valid 
both for surfaces and faceted models. 

 

Dimensions and Annotations 

For communication and documentation purposes it is many times important to 
include dimensions and annotations to be stored with the model. The  
Dimensions menu gives us the tools to add dimension information to the model. 
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 - Set the Shell Selection mode for the next lessons with the 

 

shortcut button. 

Measuring and annotation commands area available through the Dimensions 
menu or through the toolbar: 

 

 

 

If the toolbar is not visible,  

 give the command View > Toolbars > Dimensions Toolbar. 

Let's first take an absolute point value from the slubox-gap model.  

 Rotate and zoom the model so that you can see it as shown on the 
below: 

 

 - Now give the command Dimensions > Point Value (       icon) .  

The Crosshair icon is shown on the display area and the program is waiting for 
you to select a point on the model for coordinate values. Select one point from 
the model and you will see a result like below (in the green circle): 
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Let's now try distance between two points (yellow circle below). This is done with 

 command Dimensions > Distance or       icon. 

After you give the command you will see a new Crosshair icon. The number 1 
beside the crosshair icon tells you that it is waiting for the first point for the point 
distance evaluation. Now select the first point and the second point (crosshair 
with number 2 beside it) so that the result would look like the one on the previous 
image. Press RMB to accept or ESC to quit or cancel a selected point. 

In the same way you can take Angle and Radius using the Dimension menu. Try 
to repeat the example shown on the next page. Keep in mind that you can Zoom, 
Pan and Move the eye point using the mouse and keyboard shortcuts. 
Dimensions > Wall Thickness allows to measure the wall thickness at a selected 
surface point.  

Pressing LMB only selects the closest surface point below the cursor for 
dimensioning. Pressing ALT + LMB causes the closest triangle corner point to be 
selected instead of the surface point below the crosshair icon. This will enable 
selecting accurate triangle corner points for point value, distance, radius and 
angle measurements. 
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Now you are ready to edit and move the annotations.  

 Click with the right mouse on top of an annotation. 

You should see the Annotations popup menu below. If you see the Display area 
RMB popup menu select the Next command in the popup menu until you get 
menu associated with the annotation, as seen below: 
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This menu allows you to Edit, Move and Delete existing annotations. Try these 
commands on the selected annotation.  

You can also add free annotation texts and messages with Dimension > Mark-up 

command (      ). 

You can display model information on the screen by simply giving the command 

Dimensions > Object Info (      ).  

To copy the object info into the cut buffer give command Dimensions > Copy 

Object info (         ). From the cut buffer it is easy to paste the information to 
Excel, for example. 

The dimensioning can be made Sticky through the Preferences tab (see Edit > 
Preferences > General Tab) and you can give as many Point Values, Point 
Distance etc. commands as needed without the need to repeatedly restart the 
command. In the Sticky mode you should press ESC or RMB to quit when you 
are ready. You may try it now but remember to turn Off the Sticky mode before 
continuing.   

You can now delete all annotation by pressing   icon. 

 

Repairing slubox model 

Now it is time to repair the gap in the slubox-gap model. Note: this repair cannot be 

done with Free View Expert, a licensed higher level Expert Series module is required.  

Make sure the shell 1. slubox-gap (Verified) is selected in the Model Tree. Then 

 give the Fix Model > Repair Shells command and 

you will see the following parameter dialog:  
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 Just press OK when the parameter dialog appears and you will have 
correct slubox model in a second: 

 

 

 

 - Press OK to close the Status message dialog.  

This was the first lesson covering viewing, dimensioning, popup menus, object 
selection and other basic software usability issues. In the sequel we will show the 
use of the actual repair and 3D model manipulation commands.  
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Lesson 2 – Fully Automatic STL fixing  

This lesson shows you how to fix an erroneous STL model for 3D Printing or 
simulation software use using the automatic tools with Expert Series software. 

Green box indicates if this lesson is applicable to given module: 

 Free View  Dimensions  Lite  3Data  Sim 

 

Clean up the software workspace before continuing by  

 giving the File > New command. Do not save the result of the 
previous example. 

 

Auto Repair process for  STL files 

When inputting a triangulated model into 3Data Expert an automatic analysis and 
repair process is started. In normal everyday use you can correct most of the 
models using the Auto Repair process.  

 First open the dino-connected.stl file in the Tutorials / GeomFiles 
directory. 

 You will be prompted for the units, accept the proposed units millimeters (mm): 

 

 - Press OK to continue and  

you will be prompted for the Operation Mode. 3Data Expert has four main 
operation modes: Fix Model, Paint & Texture Model, Print Preparation, and View 
Model mode (Operation Mode window may look different if you are running 
Dimensions Expert or some other module):  
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 To start fixing press the Fix Model button in the Operation Mode 
dialog now. 

Expert Series will begin automatic model verification (Fix Model > Verify Shells 
command). The screen is erased and a progress bar appears. When the analysis 
is ready, the Auto Repair dialog with Model status message is displayed  

 

The message indicates that there is one verified shell, which also contains errors. 
The display shows red Gap curves through the surfaces. Gaps are an error type 
you must fix during the repair process.  

 

 Press the Yes button to initiate Auto Repair. The parameters are 
automatically set correctly.  

Auto Repair will attempt to fix all shells with errors. When you only have one shell 
in the Model Tree you should always try Auto Repair first.  

When Auto Repair is started the shell is run through the automatic repair 
command (Fix Model > Repair Shells command) using automatically calculated 
parameters. For each shell, a progress bar shows the progress of the repair. 
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After the Auto Repair process finishes the following message is displayed for the 
dino-connected model:  

 

 Press Close button in the upper right corner to close the window. 

 

The model is ready for output and 3D printing.  

 

During Auto Repair, Expert Series attempts to fill all gaps and remove non-
manifold triangles (overlapping triangles, multi-edge triangles, duplicate triangles, 
triangles having less than three neighbors, etc.) from the model. Also, duplicate 
and overlapping surfaces are identified and optimally joined. To see more about 
triangle errors, please access the “Triangle errors” page in the Online Help 
chapter “Handling Faceted Files”. The dino-connected.stl model only has simple 
errors, like inverted triangles and gaps, which are all fully repaired during the 
Auto Repair process. You can now continue to save and print the model, as 
indicated by the status information in the Fix Model Tab Help Text window.  

  



Expert Series 12.1: Tutorial 1 – Working with 3D Models  

 Page 32 

Lesson 3 – STL fixing  

This lesson shows you how to fix slightly more erroneous STL model for 3D 
Printing or simulation software by using the automatic tools with Expert Series.  

Green box indicates if this lesson is applicable to given module: 

 Free View  Dimensions  Lite  3Data  Sim 

 

Verifying and repairing the STL model 

Start this lesson by  

 File > New command to clean up the workspace. Do not save the 
result of previous example.  

 File > Open the STL model Tutorials > GeomFiles > dino-
separate.stl. 

The software will prompt you for the Units and Operation mode as usual.  

 Accept millimeters (mm) units and 

 start the Fix Model mode. After a while the software displays the Auto 
Repair dialog with Model status message:  
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This is the result of the automatic analysis (a separate verification of the input 
model with Fix Model > Verify Shells would yield similar result). We can see that 
the 9 shells in the Model Tree are all separated by thin gaps. 

The latest automatic verification and fixing functions in Expert Series have now 
analyzed the model and propose the following repair actions:  

 Normal repair to stitch separate shells into one shell. This is done when 
more than 70% of the open edges between the different shells can be 
joined 

 Fill gaps in all shells is proposed as there are now open/flat shells in the 
result which may require Offset or Extrude for proper fixing to solid shell.  

 Remove tiny shells, less than 0.01 % of the total size is proposed. This will 
ignore all insignificant shells smaller than the given size in the final result. 
Minor shells can be the result of needle triangles and other minor errors in 
the model.  

We will now repair the model with complex gap errors into one single shell with 
the Auto Repair process.  

 Press Yes to run the automatic repair on the model 

After a while we will have a fully repaired model in the Model Tree, ready for 3D 
Printing.  

 

 Close the dialog by pressing the Close button in the upper right 
corner of the message dialog 

 

Verifying and repairing, take two 

In the previous versions (10.0 and earlier) it was necessary to run the automatic 
repair for this model through Fix Model > Repair Shells command. Below the old 
way to fix dino-separate.stl file is repeated to emphasize the development with 
new Auto Repair process show above as well as to learn some basic concepts 
on model errors.  
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Restart the lesson by 

 File > New command 

 File > Open the dino-separate.stl 

 Accept millimeters 

 start Auto Repair by pressing Fix Model in the Operation Mode 
window 

You will again see the Auto Repair dialog with the status message. 

 press No to quit Auto Repair process 

 

 

 

A status dialog appears:  

 

 

 

 When the status dialog is displayed, press OK to close it. 

The dino-separate.stl part is split into nine shells (components) which together 
will make the full part.  
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Using Repair Shells command 

Thin gaps between the surfaces in a triangulation is normally caused by an 
erroneous surface triangulation for 3D Printing; The surfaces are triangulated 
separately without connecting the faces at the trim curves (or surface edges). 
Larger gaps may be due to missing surfaces in the original model. With 
DeskArtes Expert Series you can easily repair these STL model errors: 

 

The dino-separate model components are sorted according to the surface area in 
the Model Tree after the Fix Model > Verify Shells command. This helps us to 
delete minor obsolete components from the model before further operations by 
just checking the last small components in the Model Tree.  

 Select the last component 9. dino-separate (Verified) and Fit it on 
the screen: 
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We can immediately see that this is an important component and must not be 
deleted. The components before the 9th are even bigger and thus must remain in 
the model.  

The next step is to combine the separate dino components into one connected 
part.  

 Use multi-selection on the Model Tree to select all components (or 
select Model Tree root): 

 

Then  

 start the Fix Model > Repair Shells command to stitch the 
components into one part and to fill in the missing soles of the dino. 

The command can be started from the Fix Model Tab shortcut button, too: 

 

Use the default parameters below:  
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There are several parameters for the Repair Shells command. The parameters 
are automatically calculated for each model and can normally be accepted as is: 

 Normal vs. Simple repair: Normal will stitch separate shells into one shell, 
if possible. Simple repair repairs each shell separately and does not 
connect them into one.  

 Fill gaps in all shells vs. No fill for flat/open shells: Fill gaps in all shells fills 
all gaps in all shells regardless of the shell shape, according to the Fill 
large gap parameters. No fill for flat/open shells leaves flat shells unfilled. 
These shells may be better to fill with Offset or Extrude surface 
commands.  

 Check for triangle errors to report intersections, multi-edge and overlap 
conditions 

 Consistency recheck to check duplicate and overlapping surfaces and use 
optimal connection algorithms between these surfaces to form a solid 
shell.  

 Stitch gaps thinner than to connect separate components where the 
distance between open edges is less than given value 

 Fill large gaps to close all gaps smaller than given value. All to close all 
soles of the dino. For textured and colored models you may want to apply 
Use surrounding texture and Use surrounding vertex colors to keep the 
original colors in the result, otherwise Foreground color is used for fill 
triangles.   

 Remove tiny shells where the area/volume is less than 0.01 % of the total 
area/volume.  

 

 check that parameters are as in the image above and then press OK 
to start Repair Shells command 

 

After a while the Repair Shells will finish and the status is displayed:  
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The software reports a fully fixed model which can be printed with a 3D Printer. A 
close-up at the leg/body connection shows how the triangles are stitched at the 
gap area (in shaded+wireframe mode below): 

 

 

 

We have now fixed two models with relatively simple errors. For more information 
on how to fix more difficult STL and VRML models, please see the 3Data Expert 
12.0: STL and VRML repair examples document. The document covers the fixing 
of several difficult models for 3D printing and Additive Manufacturing.  
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Lesson 4 - Splitting and Combining STL 

This lesson shows you how to split large STL models for 3D printing and Rapid 
Prototyping. Building a very tall part may be more expensive than building two or 
more lower parts simultaneously. Also, the building area may not be large 
enough for a very big part. Correct joining of the split parts is ensured by adding 
guiding pins to the models.  

Green box indicates if this lesson is applicable to given module: 

 Free View   Dimensions  Lite  3Data  Sim 

 

Splitting the dino model 

Start by  

 inputting the DeskArtes geometry file DinoOk.3de In the Tutorials 
/ GeomFiles directory. 

 Set the file type to .3de to input DeskArtes proprietary files: 
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The DinoOK.3de file includes a correct triangulation for the familiar dino-model. 
You should accept the proposed units and  

 go directly to the Print Preparation mode by pressing the 

 

 

button in the Operation Mode Window. You should see the following dino model:  

 

with the Print Preparation Tab on the right hand side of the screen. 

 

The Print Preparation Tab gives 
shortcuts to the mostly used print 
preparation commands, like split, 
connect, add lap joint, hollow, offset,  
drain hole, slice and supports. The Help 
Text provides context sensitive help to 
the commands. Note: The contents of the 

Print Preparation tab depend on the Expert 
Series module in use.   
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 Select node 1. DinoOk (Repaired) by clicking it with the left mouse in 
the Model Tree. 

Before the splitting we must take a correct view to the model because the 
splitting plane is generated by extruding a user drawn split polygon away from 
the viewer. With 3D Printing the correct way normally is to split the model 
perpendicular to the z-axis to make the part lower. Thus,  

 take a view from the x-axis direction with View > Ortho View > 

Front (+X)  (   + LMB). 

 

 

The splitting is  

 started now with command Print Preparation > Split or with icon 

 

 

The system prompts you to take the correct view direction if no yet set:  
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When the view is correct you can  

 press Continue or Cancel to quit. You may hide this window 
permanently when not needed anymore. 

The system asks you if you wish to use a Polyline (linear), Curved split line or 
exact Coordinate value.  

 Select Polyline 

 

 press OK and the system goes into the curve edit mode where you 
can define the shape of the splitting surface. 

 

Now you can draw the shape for the splitting surface.  

 Draw a horizontal line by giving two points with the LMB clearly 
outside of the dino model 

as seen in the image below:  
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The curve editing is finished by  

 pressing the RMB (or ESC key to cancel if you need to redraw) 

When finished the model is split along the plane defined with the user drawn 
polyline, Select the first shell in the Model Tree to highlight the up halve: 

 

 

The two halves are grouped and named with a- and b- prefixes to distinguish 
between the shells above the split line and below the split line.  

Note: If you are splitting models with more than one shell you can select the a or b part with 
the Groups command in the Model Tree popup menu.  
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Creating the pins 

The separate parts of the model could now be stored into .stl files for 3D Printing. 
However, the precise joining of the ready parts would be difficult or impossible. 
To be able to position the parts accurately after the build we shall add pins and 
holes in the shells to connect them together when ready from the 3D Printing. 

First we will select and show location to the necessary primitives which will 
connect the two parts together. For that we will get a nice view to point the pins 
on the screen. Here we are also using the shaded+wireframe view mode through 

the         icon in the Viewing Toolbar.  

 Rotate the model to position shown in the image below 

 erase the screen with      and  

 select the lower part of the dino and Fit it    on the screen, so 
that it is displayed properly on the screen 

 set on shaded+wireframe mode with    icon 

Zoom close to the model to be able to accurately position the pins: 

 

The pins are now  

 added with the Print Preparation > Connect command or 

using the Print Preparation Tab shortcut 

 

After the command is given, it is possible to give the shape and the size for the 
pin to be created. Set Diameter and Length both to 10.0, as seen below:  
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The positions for the pins should look similar to the image below.  

 

 

 

If a pin is incorrectly located on the shell you can remove it by clicking the red 
indicator cone again with the LMB. Then reposition the pin again with the LMB 
click. 

When ready  

 press OK to generate the connectors. 
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After a while you will see the connectors added to the selected shell (in shaded 

mode again with      icon in the Viewing Toolbar):  

 

Corresponding holes are automatically created to the a-dino-connector shell. You 
should move the shells apart from each other with the Transform menu 
commands prior to outputting the model for 3D Printing.  

The connector is positioned on the surface so that 10% of the height is below the 
pointed surface for robust Boolean operation between the selected surface and 
the pins. 90% of the pin length is above the surface and will be cut into the 
opposite part.  

 

Saving the result 

You can save both files into the same STL file by selecting the Model Tree root 
All. Anyhow, you normally want to build and position the parts separately in the 
3D Printer. For that select each shell separately and  

 output it to a proper STL file with File > Save As command. 

If you wish to save the two parts into one file, you should move the shells apart 
from each other with the Transform or Print Preparation > Move Platform menu 
commands prior to outputting the model for 3D Printing. To output one file, select 
the Model Tree root All before the Save As command.  

 



Expert Series 12.1: Tutorial 1 – Working with 3D Models  

 Page 47 

Using Lap Joint to connect thin parts 

With this example we will split a part with thin walls and connect it with a lap joint 
connection. A lap joint is a small overlapping structure on both sides of the wall 
along the split surface edge. With Lap Joint command you can generate strong 
bond even along very thin walls.  

First we will input the familiar slubox-gap.stl file and repair it for Splitting: 

1. Input file slubox-gap.stl file with File > Open. 

2. Accept millimeters as units. 

3. Press Fix Model with Operations Toolbar to go to the Auto Repair 
process. 

4. When asked “Do you want to run Auto Repair” press Yes. 

5. And after a while you will get “Congratulations, the model is correct 
and can be saved and printed” message.  

6. Press Close button in the upper right corner to close the status 
message window.  

 

You now should have the slubox model fully repaired for splitting: 

 

 Now take a suitable view direction +Y for splitting by pressing     

icon:  
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Start the model splitting with  

 Print Preparation > Split command now and 

 select Split curve type Curved line, as seen in the next page.  

This time we want to make a split line which is not straight, i.e. it has teeth, and 
the split line corners are slightly rounded. This will allow us to create a 
connection with no freedom of movement between the split parts as well as to 
avoid small holes between the connected halves due to too sharp corners in the 
split plane.  

 



Expert Series 12.1: Tutorial 1 – Working with 3D Models  

 Page 49 

 Press OK to start adding curve points. 

For each split curve point at the curve corners below  

 press twice for each point with the left mouse (points inside the 
green circle below). 

This will generate a rounding with small radius at each corner (single click would 
generate a “wavy” split line): 

 

 

Or if even a bigger radius is needed at each corner, create two points close to 
each other, not double points. This will increase the radius at each corner and 
allow to use bigger Lap Joint Height values later, for example.  

When ready drawing the split line,  

 press RMB to split the model: 
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If you now display the selected half of the model and zoom closer to the teeth, 
you can see that there is a small rounding to enable more accurate building of 
the part without cracks at the sharp corners: 

 

 

 

Adding Lap Joint 

You are now ready to start generating the Lap Joint.  

 Give the Print Preparation > Lap Joint command. 

You can also start it by pressing the Lap Joint icon in the Tools Window Print 
Preparation tab:  
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Let's now fill in the parameters for the Lap Joint command. It is important to use 
parameters suitable for the split part. The Lap Joint Depth (2 mm) must not be 
too deep when compared to the wall thickness (about half) and Height (2 mm) 
should be suitable to create a strong bond between the two halves after the build. 
There are also three different Lap Joint Types available, this time we will  

 use Thin wall type to create the lap joint structure just on one side of 
the part. 

 Fill in the parameters seen below:  

 

The Allowance 0.1 mm will leave a small void between the lap joint halves for the 
parts to fit easily and to allow for adding adhesive between the lap joint halves.  

You are now ready to select the Lap Joint locations. Locations must be selected 
along the split surface edge. When a lap joint location is selected, a red indicator 
box appears on the edge and the lap joint area is show with yellow indicator 
boxes. The yellow indicator boxes allow you to check that the lap joint is correctly 
located as well as that the Depth and Height are reasonable. Also, if the yellow 
boxes intersect each other, the generated lap join may not be valid. To redefine a  
lap joint, click the red indicator box and the lap joint disappears. Modify the 
parameters or press another point to change the location, if necessary.  

You can use mouse wheel zoom and middle mouse rotation during the Lap Joint 
command to visually check the lap joint area.  

As in the image on the next page  

 select two locations indicated with red boxes. 
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The yellow boxes show the size and location of the corresponding lap joint 
structures: 

 

 

 

When ready defining the lap joints,  

 press OK to create them. 

The lap joint structure is automatically deleted from the displayed part and added 
to the other split halve (thus you must not move the split parts before adding lap 
joints between them).  

Note also, that the lap joint positions (red boxes) are selected at the edges of 
well behaving triangles (not thin), this will ensure the best possible result with the 
lap joint generation.  

After pressing OK the software checks if more than one lap joints should be 
generated.  

 

 Press Yes to generate both areas. 
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After a while you will see the results, lap joint structure deleted from the other 
part and added to the other halve: 

 

Parts can now be outputted and build separately and then accurately joined and 
glued back together.  
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Lesson 5 – Positioning Parts 

This lesson shows you how to use the Expert Series commands to position parts 
before transferring to Additive Manufacturing machines. The Platform definition 
and Move to Platform commands are accessed through the Print Preparation 
menu.  

Green box indicates if this lesson is applicable to given module: 

 Free View   Dimensions  Lite  3Data  Sim 

 

Note: Most 3D Printing systems will reposition the part when inputted into the 3D Printer control 
software.  

 

Defining Platforms 

The DeskArtes Expert Series has a user friendly interface for defining and 
manipulating the available RP platforms.  

- Restart the 3Data Expert software or clean up the workspace with File > 
New command.  

 Give the command Print Preparation > Platforms. You will see the 
following dialog: 

 

This dialog includes the commands to manipulate the set of available platforms. 
Let's make our first 3D Printer workspace  

 by pressing New button. 

The Platform Settings dialog will appear. 
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The shape, size, slice thickness and z-compensation values you will find in the 
machine specifications. Here we will use an imaginary MyRP machine as an 
example.  

 - Please fill in the values as in the figure below: 

 

In this example we have selected the size to be 250x250x250 mm. The slice 
thickness is set to 0.01. This value depends on the specifications of your RP 
machine. The slice thickness here is used with the Print Preparation > Slice 
command automatically. The Z-compensation value is used with the Print 
Preparation > Z-compensation command automatically. 

Now we are ready and you can  

 press OK to save the platform and to close the dialog. 

 

Now we have our first platform definition in the Select Platform list. 
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More platforms can be defined in similar way. When you are preparing data for a 
specific platform you do not need to remember different parameters for the 
machine anymore, just select the correct platform from the list. 

If you are not happy with the definition of a platform you can either Modify it or 
delete it with the Delete command. 

Note: Since there are no units given in the platform definition window you must name the 
platforms according to their units, like MyRP-mm or MyRP-inch, to distinguish them from each 
other.  

 

To be able to see the platform on the graphics area,  

 press the Show button in the Platform dialog.   

 Press OK to close the Platform dialog. 

You should see the model tree and drawing area as seen below. If the grid is not 
displayed, go to Edit > Preferences > Viewing  tab and turn On the Show Grid 

toggle or press    toolbar button. In the shaded viewing mode only the 
platform bottom plate is shown as shaded. Below we are displaying the platform 
in shaded mode with grid.  

After initially loading the Platform you can Show/Hide it with the   icon.  
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Moving parts into the platform 

Now we will see how the Print Preparation > Move to platform commands are 
used for positioning the part into the used platform. We have selected the MyRP 
platform as the current machine definition earlier. The move platform commands 
will now use the minimum/maximum x,y,z values of this platform when computing 
the default values for the moves. 

Let's first  

 input the model Tutorials/GeomFiles / rava2.stl using the File > 
Insert command 

(we insert to avoid emptying the Model Tree with Open command). When the 
Operation Mode must be chosen,  

 select View Model mode to avoid unnecessary file analysis and fixing 
at this point. 

 Close the miniature Operation Mode Window by pressing its close 
button.  

Also ensure that the MyRP platform and the Model Tree are visible: 
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We can see that the part is not inside the build area.  

 First select the part rava2 from the Model Tree and then 

 move the part into the area with the command Print Preparation > 
Move to Platform > Move positive.  

The command suggest the default values which are the same as the minimum 
bounding box values for the selected platform MyRP.  

 Fill in the values below and press OK. 

 

 

This means that the minimum corner point of the part bounding box is set to the 
given values. You can check this by taking a view from the +X  direction:  
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Then  

 give Print Preparation > Move to Platform > Move center 
command. 

Move Center computes the center point of the selected platform and uses this as 
the default for x and y values. The xy-center point of the object is moved to this 
point. You still have to give the z distance from the bottom of the vat (to allow for 
supports, for example).  

 Fill in the level value below and press OK. 

 

 

You should have the result show on the next image:  
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The Move to Platform > Move Level command only moves the part in z-axis 
direction to add sufficient space for supports.  

You may want to try the normal transformation commands also. For that make 
sure that the Transformation toolbar is visible by giving the command View > 
Toolbars > Transform Toolbar 

 

 

This toolbar includes commands for part moving, scaling, rotation and mirroring.  

There are more commands in the Transform menu, like numeric transformations, 
scale from MM to Inch and the other way around.  
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Lesson 6 – Nesting 

This lesson shows you how to use the Expert Series commands to position parts 
automatically using 3D Nesting.  This is done with Print Preparation > Nesting 
Tools > Nesting command. Currently 3D Nesting is available for efficient part 
merging for powder based system which do not require supports during the 
manufacturing.  

 

Green box indicates if this lesson is applicable to given module: 

 Free View   Dimensions   Lite  3Data  Sim 

 

3D Nesting regular components 

In this example we will pack a set of consistently ordered similar components into 
the work area, aka bin with nesting. The goal is to organize 73 scaled rava2 parts 
into the bin as effectively as possible. You can also display the MyRP platform 
defined in the previous chapter during the exercise.  

In the image below we have 73 original components show in the left hand image 
and nested 73 components in the right hand image: 

  

 

Before nesting we need to generate the 73 components to nest: 

- Input rava2.stl and run Fix Model process on it 

- Use Transform > Scale > Numeric to scale it to 50% of the original size 
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- Create an array of objects with Edit > Copy to Array command ( ) 

 

- You will see an array of 72 components added to the Model Tree 

 

- Select Copy Array and run Fix Model > Verify Shells command on all 
components to separate each part into its own shell 
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- After a while you will have the original and 72 separate new shells in the 
Model Tree 

 

 

We are now ready to start nesting the parts. You may want to read the Help 
pages for Nesting command to generally learn about the different parameters 
available for the Nesting command. In the sequel we will make some specific 
changes to the default parameter set to get the best possible nesting result for 
the rava2 array.  

We will start the nesting by 

- Select the Model Tree root All 

- Give the Print Preparation > Nesting Tools > Nesting command and 
you will see the Nesting paramters dialog.  

Fill in the parameters below, if not already set. Especially note the Orient 
algorithm = z-rot and Init algorigihm = bin split. The component directions will not 
be changed during the nesting and the bin initialization is done by splitting the bin 
into boxes which fit each component. 30 second run time is sufficent because the 
most of the nesting is performed by the Initialization alogrihm (bin split).  
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- Press OK to start the nesting 

- About 30 seconds later you will have the result in the Model Tree: 

 

 

Generally, it is useful to position the components so that the longest edge is 
along the longest edge of the bin. If the Orient algorithm is set to z-rot or xyz-rot, 
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the software will make an attempt to find the longest component edge and align it 
to the longest bin edge before the initial bin fill.  

 

3D Nesting irregular components 

When the components are more irregular and/or different sizes, different 
initialization and orientation algorithms can be used to achieve better results than 
simple z-rot/bin split algorithms would give. We will give a couple of examples 
here and also show how the allowed nesting time affects the results.  

First we will prepare a set of dino components to nest: 

- Input dino-separate.stl and run it through the Fix Model process 

- Scale the model to 50% of the original size 

- Create Array of 49 components 

 

- Run Verify Shells to separate the Copy Arrya to shells 

Now you should have a set of 50 dino shells in the Model Tree. Show also the 
MyRP platform for reference.  
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First we will run the shells through the same parameters as was done with the 
rava2 example above. We will use a bit longer run time, 1 min 30 sek. 

- Select Model Tree root All 

- Give command Nesting with the following parameters (orig-dir, bin-split):  

 

- Press OK to start nesting 

- After a while the result is available in the Model Tree. 
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This time all shells did not fit into the workspace. Anhhow, with more dense 
merging the shells should fit there.  

Let’s try another nesting with z-rot and rain-fall methods: 

- Undot the current nesting with Edit > Undo command 

- Start the Nesting command again with the following changed 
parameters: Orient alogrithm = z-rot and Init alogrithm = rain fall. 

 

 

This time the nesting should be lower or even fit into the bin. In the image below 
is one example of the new nesting result:  

 

 

- Now rerun the Nesting on the shells. Answer Yes to the question asked 
after the OK is pressed. This will continue with the existing nesting and 
improve it using the nesting algorithm.  
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After the command is run you should have a build that fits into the given 
workspace, please see the image next page. If not, you can rerun the command 
until all shells fit into the bin.  

 

 

 

You can still try another Orient algorithm, xyz-rot (marked with red line below), 
where the shells can be rotated freely during the nesting.  
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The result will be similar in height than the previous exaple, and can be improved 
by rerunning the command on the result.  

 

 

The most important parameter affecting the resulting packing density is the 
allowed run time. Above we were using 1 min 30 sec run time. Below is an image 
of the three different Init – Orient algorihm combinations with 30 minutes run 
time. All different results fit into the workspace and this time the z-rot/rain fall 
cobination gave the best result (middle):   

   

Orig-dir / bin split z-rot / rain fall xyz-rot / rain fall 



Expert Series 12.1: Tutorial 1 – Working with 3D Models  

 Page 70 

Lesson 7 – Adding 3D Text 

 

Sometimes it is necessary to add decorative texts or tag parts with individual 
texts to tell them apart after the build. Expert Series 3D Text adding and Boolean 
commands make marking part easy and effective.  

Green box indicates if this lesson is applicable to given module: 

 Free View   Dimensions  Lite  3Data  Sim 

 

Creating 3D Text 

Normally you want to add the 3D text on a part to be built. To start the lesson, 
first input and repair slubx-gap.stl: First we will input the familiar slubox-gap.stl 
file and repair it for adding text: 

1. Input file slubox-gap.stl file with File > Open. 

2. Accept millimeters as units. 

3. Press Fix Model with Operations Toolbar to go to the Auto Repair 
process. 

4. When asked “Do you want to run Auto Repair” press Yes. 

5. And after a while you will get “Congratulations, the model is correct 
and can be saved and printed” message.  

6. Press Close button to close the status message window.  

 

.You now should have the slubox model fully repaired for adding 3D text. Take a  

 view from Y axis direction and 

 give the command Create Geometry > Create 3D Text:  
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Fill in the values given in the dialog above: Size 12 mm (vertical height), Height 1 
mm (=text height from the surface) and finally String “slubox repaired”. The font is 
preset to Arial, well use that. Show position on surface is set. When we  

 select Surface operation Engraving. 

 make sure Show position on surface is set. 

 press OK the program asks us to show a line on the surface along 
which the text will be generated. 

 You can now position the text with LMB on the correct location. 

When positioning the text just make sure the whole text fits on the flat surface 
area on slubox:  
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If necessary, you can scale and rotate the text on the graphics area to better fit it 
on the slubox model. The yellow Help text window on top of the graphics area 
shows the different text positioning options available.  

Soon you will see the text engraved on the slubox surface: 

 

 

Generally, 3D Text can be attached both on flat and curved surfaces. If the 
surface is curved, you should use the Curved surface option to reliably attach the 
text on the surface. If not used and the surface is too curved along the given text 
path, some letters may not be attached to the part or may be fully inside the part.  

 

Adding 3D Text to multiple parts 

Sometimes it is necessary to add text and label strings to multiple objects at 
once. For example, marking objects for platform location related quality checks 
may need.  

The new functionality also enables adding indexed Label string into the shell the 
3D text is added (engrave or embossed) which will help to identify each 
component with the Production Screenshot image or with Generate Report 
documentation.  

Note: The parts which will be added with the same text must be rather similar. 
The text position is defined in relation to the bounding box middle point of each 
component. If the shape of the components is very different, the text may end up 
in the wrong location in different shells.  

For this example we are using the 12-cellphones.3de file in the GeomFiles 
directory.  

- Input the 12-cellphones.3de file 

- The file contains a workspace which can be turned off with Show/hide 

Platform button   
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- Take a view from Z direction 

- Zoom into one of the shells 

 

 

The goal is to add an identifying string to each of the components for 
identification after the build. Improved 3D Text command with its new fields Set 
production Screenshot label string and Apply text to all multi-selected objects 
does that:  

- Keep Model Tree root All selected 

- Give the command Create Geometry > Create 3D Text 

- The Text Input dialog appears. Make sure all the values are as seen in 
the image next page: Letter size, Height, Show Position…, Set Production 
…, Engraving, Add index…, Apply text to… etc. The shell is rather thin, so 
especially the Height/depth must be very small.  
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The goal is to add an identifying 3D string to each of the components for 
identification after the build. Improved Create 3D Text command with its new 
fields Set Production Screenshot label string (green circle above) and Apply text 
to all multi-selected objects (yellow circle above) does that. Add indexing to the 
string (blue circle above) causes the string index to be increased for each 
component.  

- Press OK to start positioning the text on the shells 

- Use the upper leftmost shell as a reference to position the text on top of it. 
Move the text with LMB and rotate with Ctrl+LMB: 
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When the text is at the correct location on reference to the upper left shell,  

- Press RMB to add the text to all selected shells 

- After a while the result is visible at the Model Tree, each component has 
the text with increasing index added: 

 

 

 

The Text is added starting from the last selected shell in the Model Tree before 
the command was given and continues towards the shells higher in the Model 
Tree. Before the command the highlighted shell was the last in the Model Tree 
and will get the text “cmp00”: 
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After the command the last shell is the first in the Model Tree with the “cmp00” 
text: 

 

 

The Labe string can be checked with Object Properties command:  
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- Save the resulting model as  12-cellphones-3D-text.3de for the later 
lesson on Production Screenshot command.  

 

Adding 3D Text on curved surfaces 

The new Create 3D Text allows adding 3D text on curved surfaces too. Anyhow, 
you need to right size “tool” to ensure the 3D text is visible on all desired 
locations.  

Let’s create a primitive cylinder with 20 mm height and 10 mm radius for this 
lesson.  

- Crate a cylinder with Create Geometry > Primitive > Cylinder 
command 

 

- Press OK to save the cylidner and then  

- Run Fix Model > Repair Shells comman with default parameters on the 
cylinder model. You should have a clean cylinder in the Model Tree now:  
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We will now add simple text on top of the curved cylinder vertical side.  

- Start Crate 3D Text command and fill in the following parameters, 
especially note the 400% Tool depth. This will use up to 8 mm (4*2mm) 
high letter primitives to cut the text on the curved surface.  

 

- Press OK to show the location on the model 

 

- You can quickly see the “tool” surafaces used for the boolean operation 
before the actual result:  
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- And finally the correct result: 

 

 

The text is correctly cut against the model. Let’s try the operation with a smaller 
“tool” height.  

- Undo the last command 

- Give Create 3D Text with 100% tool height 
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- Press OK to add the text 

- The end result is a model where the text is not properly attached to the 
cylider model, as can be seen in the wireframe model below:  

 

 

So, it is important to use high enough tool height with highly curved surfaces. 
Also, to get the most accurate text projection on the surface, the viewing should 
be as directly towards the average normal of the text insert surface, othrwise 
some anomalies may appear.  
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Lesson 8 – Generating AM reporting 

This lesson shows you how to do surface verification and triangulation to produce 
a solid 

 

Production Screenshot command 

3Data Expert 12.1 introduces new Manufacturing menu. This menu is intended to 
contain commands which are closer to the ready built AM part. Currently it 
includes commands to produce documentation for post-processing operations 
and quality control.  

The Production Screenshot command is meant for generating documentation to 
help identifying the parts on the platform after the build. First the user sets up the 
suitable part positioning and orientation on the build area for the parts and 
supports. When ready to go for slicing it is time to produce the Production 
Screenshot. Here we are using as an example the result from the previous 
example, 12-cellphones-3d-text.3de file.  

- Input the 12-cellpohnes-3d-text.3de  

- Skip the Auto Repair process 

- Give the command Manufacturing > Production Screenshot.  

 

You will soon see a view from the positive Z axis with additional yellow info boxes 
for each component on the platform (e.g. Model Tree).  
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Each info box is connected to the corresponding component with a red line (close 
to the middle of each component). In this case the Label strings stored in with the 
3D Text command are also visible in the info boxes, as the engravings on the 
components. This will make identifying each component after the build very easy. 
The properties (size) of the building platform are also shown on the upper left 
corner of the platform. 

The Export as image button allows to save the image with a desired name on the 
hard disk. OK will store the screenshot into the Model Tree for later viewing with 
Show Production Screenshot command: 

 

The exported .png file can be inputted or copy/pasted to different MS Office 
documents, like Excel, for part identification and commenting after the build.  
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Generate Report command 

Generate Report command in Manufacturing menu will allow to automatically 
transfer model and geometry related info into MS Office documents for quality 
control purposes. The transferred data will include model name, volume, surface 
area, size, dimensions, etc. and can be fully defined by the user. The data 
transfer is based on predefined templates when in everyday use. For detailed 
description of the system, please see the application Help page Menus and 
commands > Manufacturing menu > Generate Report. 
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Lesson 9 – Preparing for 3D Printing 

There are several issues to take into account when sending 3D models for 3D 
printing. Most processes are more effective when printing bulky models hollowed. 
Also, being able to drain out the excess material from a bulky hollow model 
enables remarkable material savings. Open flat surfaces must be offset to a 
certain minimum thickness to print properly and too thin walls require material 
addition to print properly. Some processes require external supports to build 
correct models.  

3Data Expert offers effective tools for preparing 3D models for optimal print result 
through its Print Preparation menu. For this and following lessons 3Data Expert 
software is mostly required.  

Green box indicates if this lesson is applicable to given module: 

 Free View   Dimensions  Lite  3Data  Sim 

Making Hollow models 

Building large and bulky models may require long time to print or consume large 
amount of material. If these models are made hollow the processing time as well 
as the material usage will be minimized.  

Start this exercise by  

 emptying the 3Data Expert work space with File > New and then 

 input the model Tutorials / GeomFiles / DinoOk.3de.  

 Go directly to the Print Preparation Mode 

 

 

Dino model is a bulky model suitable for hollowing.  

 Give the command Print Preparation > Hollow or use the 
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shortcut in the Tools Window. When the command is given the following 
parameter dialog appears: 

 

The dialog gives the extents of the selected part on the Selected object size and 
units group. The default Minimum wall thickness is calculated based on the 
maximum extent of the selected object (13.67 mm in this case). The default value 
is too large for this model, change the default Minimum wall thickness value to   4 
mm as seen in the image above.  According to default Advanced settings we will 
make the hollowing surface Inside the Dino model and use default Accuracy.  

 Fill in the parameters above and 

 Press OK to start the hollowing.  

After a while the Hollowing is ready. To see the actual result you can use the 
Clipping to look inside the model. As seen in the image below, the model is now 
made hollow by adding a new surface inside the original surface.  

 

The hollowing is done by filling the inner void of the model with empty boxes. The 
size of the boxes is defined by the Minimum wall thickness and Accuracy settings 
in the parameter dialog. The inner surface triangles are generated where the 
distance of an empty box wall from the original surface is at least the given 
Minimum wall thickness. This guarantees that the wall thickness is at least the 
given value.  
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The Hollowing command can only be used with solid models. If you wish to make 
an open surface a solid you should use the Print Preparation > Offset command.  

We will use the result of the hollowing in the next chapter where we make a drain 
hole to the hollow model.  

 

Making Drain Holes 

Drain holes are needed when building Stereo lithography or powder based 
hollow parts with large trapped volumes. The Print Preparation > Drain Holes 
command gives an easy way to make holes of desired size in the STL models. 

We will continue with the result of the previous example, hollowed Dino model.  

 First take a suitable view of the dino model to see the underside of 

the model by pressing the        icon with the RMB: 

 

 

 Give the Print Preparation > Drain Hole command or press 

 

shortcut to start the Drain Hole command. A parameter dialog appears (on the 
next page). This time the default values are also calculated based on the 
maximum extent of the selected object.  

 Modify the Diameter and Wall Thickness values, as seen in the 
parameter dialog image below  (15 and 9 mm respectively): 
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The Wall thickness parameter value depends on the wall thickness of the part in 
the position we want to put the drain hole. Here we will create the hole in the 
middle of the part bottom where the wall thickness is about 4 mm, but not less. A 
bigger value, like 9 mm, is used to make sure that the hole will go through the 
hollowed surface. 

The pins are positioned with LMB clicks on the display area on top of the dino 
model. Give the hole location in the middle of the bottom surface. Note that you 
can use the MMB zoom and MMB rotation to change the view point when 
locating the connectors.  

 Position a drain hole with LMB in the middle of the bottom surface 
as seen below: 
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If the hole location is not correct you can remove it by clicking on the red 
indicator box again. Then reposition with another LMB click on the correct 
location.  

When ready  

 Press OK to start the Drain Hole generation. 

After a while the Drain Hole is generated parallel to the surface normal at the 
given location.  

 

Drain Holes can be generated on any wall, it is always created parallel to the 
surface normal at the given location.  

 

Making tapered plugs with Hole Tool 

The new Modify Faceted > Hole Tool is meant for generating holes with different 
shapes and depths for various applications. It can also be used to generate a 
drain hole for hollowed parts with a tapered plug. The tapered plug can be 
printed separately and glued to the printed part to close the hole accurately.  

We will continue with the hollowed dino created in the previous example. Now 
take a view from the top of the model: 

 

Then  
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 start the Modify Faceted > Hole Tools command. 

 

A Hole Tool dialog is displayed: 

 

 

Hole Tool dialog contains several 
parameters for hole generation. Now we 
want to generate a hole which is drilled 
in the surface normal direction. We also 
want to generate a plug for the hole the 
same time. The plug will have a tapering 
to prevent it falling into the part. Also, 
the plug will be done slightly smaller 
than the hole to enable easy gluing of 
the plug into the hole.  

 

Start hole generation by  

 select N-sided hole 

 use Surface normal direction for 
the hole direction  

 set Taper angle to 5 degrees 

as seen in the image beside.  

The hole location is selected graphically 
with the LMB on the model. When the 
above parameters are set we are ready 
to  

- press the New hole button to show 
the location and size of the hole.  

A crosshair icon will appear.  

- Click in the middle of the dino back 
to set the hole middle point.  

 

Then  

 draw a box by dragging with the LMB to estimate the size of the hole 
to generate. 

 When the mouse is released, a parameters dialog appears:  
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Note: Center point does not apply here, it was selected with the mouse. 

Then  

 Select Side length and set the value to 4.0. Also 

 set the Number of vertices to 8 to generate a plug with 
distinguishable corners for easier positioning after the build.  

 Then press OK to generate the plug indicator on the model, as seen 
in the image below: 

 

Hole 1 will be generated into the Hole cutters list. Now we will set the length and 
scaling for the plug.  

Then  

 Select the Hole 1 in the cutters list with the LMB. 

 For Hole depth select the From surfaces, depth and set the value to 
10.0 (to be sure to go through the dino skin). 
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 Press Apply to really change the hole depth after setting the value to 
10.0.  

 Make sure the Hole operation is set to Delete.  

 set the Create cap, relative size 98% to make the plug slightly 
smaller than the hole, as seen in the image below: 

 

When ready,  

 press Create button. 

The created hole cutter is deleted from the original model and in a few moments 
you will see the plug fitted in the middle of the screen. The dino model has a 
corresponding hole in the middle of the back.  

 

  

If you zoom closer to the hole and change the dino body to wireframe mode (with 
graphics area RMB popup menu) you can see that the plug is slightly tapered 
and smaller than the hole: 
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These two shells can now be printed separately. After the body is drained from 
non-processed material or any internal support structures are removed, the two 
pieces can be glued back together for a nice looking part.  

 

Adding thickness by Offset 

There are several software products which do not automatically produce solid 
STL data. For example, many architectural software products output open 
models made of open surfaces if not constructed carefully. These open models 
must be made solid before inputting to 3D Printing.  

3Data Expert Print Preparation > Offset command is used to generate solid 
models from open surface models. Open shells can be offset to user defined 
thickness for correct build.  

 Initialize your system with File > New  and 

 input the House.3de model from Tutorials / GeomFiles directory. 

 Go directly to the Print Preparation mode and  
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 press No to continue without repair. 

 

 

The House model contains two open shells, the roof and the walls. The open 
surface edges are given with red gap curves.  

We will use the Offset command to give thickness to the open surfaces.  

 Select the roof shell and 

 give the Print Preparation > Offset command or use the  

 

shortcut. The program will notify that there are errors in the model after you give 
the command. 

 

 Press Yes to continue the command anyhow (we will repair the errors 
by offsetting): 

 

You will see the Offset STL parameter dialog. As usual, the default offset 
distance is calculated based on the maximum extent of the roof shell.  

 - Change the Wall thickness to 2 mm and make sure the other 
parameters are as shown on the image next page.  

Otherwise we can accept the default values for Advanced parameters. 
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 Press OK to start the command. After a while you will have a correct 
solid roof in the Model Tree: 

 

 

 Now select the wall shell and 

 repeat the Offset with the 2 mm Wall thickness again. You may see 
the warning  
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 Press OK to close the dialog and start the offsetting by 

 pressing OK again in the Offset parameter dialog.  

After a while the offset is ready and you should have two correct shells in the 
Model Tree: 

 

There are some 3D Printing systems which can produce a correct result from 
these two shells directly. Some systems require the two shells to be connected 
into one shell to produce a correct result. In the next example we will join the two 
shells into one shell using the Boolean commands.  

 

Combining shells using Boolean commands 

The two shells generated in the previous example are correct but may not print 
properly if not connected into one shell before outputting for 3D Printing. We will 
use the Boolean commands to generate a single shell from the two shells.  

Let's first check how the two shells intersect each other. If you zoom in closer to 
the part and use the Clipping to look inside the shells you will notice that the 
shells truly intersect: 

Note: If the roof and the walls do not intersect you may have generated the roof offset to Back 
faces direction instead of Front faces or used too small offset thickness. If so, please start the 
lesson again and follow the instructions carefully.  

 

Reset and close the clipping window before the next command.  

We will use the Boolean command to connect the two shells.  
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 Start the Modify Faceted > Boolean command now. 

The Boolean parameter dialog will appear. It allows you to select the shells from 
the Model Tree as well as define the command to perform between the selected 
objects.  

First  

 select the 1. roof shell in the Model Tree and then 

 press the Set shell 1 button.  

 

 

The roof turns light blue in the graphics are and its name is displayed in the shell 
1 text filed. Then  

 select the 2. walls shell in the Model Tree and 

 press Set shell 2 button.  

The walls turn yellow and its name is stored in the shell 2 text field. There are 
several different operations available between the selected objects but this time 
we simply want to  

 Join (default) them into one shell. 

Make sure the dialog looks as seen below: 
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Then  

 press OK to join the two shells into one. 

After a while you will see the two shells connected into one correct shell: 

 

You may also generate the same Boolean result by multi-selecting the two shells 
and by running the Modify Faceted > Multiple Join command on them: 

 

 
 

 

Generally, there are some issues which need to be considered when using 
Boolean command. Especially important is to make sure the two shells really 
intersect each other. Tangential or overlapping shells may hot behave properly 
when sent to the Boolean operation. In these cases you should move one of the 
shells slightly or scale them slightly. The amount of move or scale should be very 
small (like 0.001 - 0.01 mm for model this size) not to affect the accuracy of the 
printed model.  

 

Generating advanced cuts with Cut Tool 

Cut Tool is meant for advanced cutting for various applications. For example, it 
can be used to cut specific details inside a 3D model without disturbing the 
surface area in the close vicinity of the cutaway detail. We will now use it to cut a 
door opening to the house model in the previous example.  

First take a view from the x axis direction by pressing the X icon with the LMB.  
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Then  

 give the Modify Faceted > Cut Tool command to open the Cut Tool 
dialog: 

 

 

The Cut Tool dialog will be used to 
define a Cutting surface to cut away the 
door opening to the model. We will start 
by selecting 

 Create cutter with Draw surfaces 

 Draw cutter with Polyline 

The profile for the cutter surfaces will be 
generated using the familiar curve 
editing tool available with the Split 
command.  

When ready  

- press New cutter button to start 
drawing the door profile on the house. 
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Then  

 input the curve points with the LMB and 

 press RMB when ready with the shape below: 

 

A new cutter surface is generated into the Cutter surfaces list: 

 

The next step is to set the Cutter surface extents so that it will only cut the front 
wall of the house model. For that  

 select the created cutter in the Cutter surfaces list. 

 select the Slider selection and use the slider to resize the cutter 
surface to correct depth, as seen in the image below 

A colored bounding box is used to indicate the cutter surface size while moving 
the slider with the LMB. The yellow bounding box indicates the maximum size of 
the cutter surface, red bounding box indicates the current size of the cutter 
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surface and moving blue lines indicate the new start and end locations when the 
LMB is released the next time.  

 

 

After rescaling the cutter surface to the depth seen above  

 make sure that the Cut operation is set to Separate. 

 Then press Cut button.  

After a while you will see the result on the screen, the cut part (left image below). 
When fitting the house we see that there is a door opening in the front wall.  
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The Cut Tool command gives you unlimited possibilities to cut models. You can 
also use several cutting surfaces simultaneously to generate even more 
complicated cuts for various applications. For example, in the next image we can 
see two cutting planes ready to remove a part from the dino tail, using cutting 
planes with different cutting directions: 

 

Note: When using multiple cutting planes make sure that the surface normal directions are 
consistent for the cut operation: For two adjacent cutting surfaces the normal must either be 
directed towards each other or away from each other. If not the normal direction for a cutter 
surface can be changed with the Swap side button after selecting the surface in the Cutter 
surfaces list.  
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Lesson 10 – Surface Triangulation 

This lesson shows you how to do surface verification and triangulation to produce 
a solid STL file from IGES surface data with Expert Series legacy surface 
triangulation system. The latest Expert Series software modules include new 
optional standard and native surface input system where the surface can be 
triangulated when inputted. The Import Translators will also keep color 
information for 3D Color printing. Please see more on application Help page File 
Types > Import translators: Catia, UG, STEP…  

For this and following lessons View Expert, 3Data Expert Lite, 3Data Expert or 
Sim Expert software is required with legacy IGES file input option.  

Green box indicates if this lesson is applicable to given module: 

 View  Dimensions  Lite  3Data  Sim 

 

Verifying the surface 

Start this lesson by running the verify operation for an IGES file:  

 clean up the workspace with File > New command and 

 read in the file Tutorials / GeomFiles / slider.igs with default 
settings. Note: Do not use the IGES (Crosscadware)(*.igs, *.iges) 
version, use the legacy IGES (*.igs, *.iges). 

 

You should see the slider on the display area and two components in the Model 
Tree, as seen below:  
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The outside of the surfaces is shown pink and the inside is shown in blue color.  

The two nodes in the Model Tree describe what has been found in the input file. 
The first component 1. slider (IGES Input) stores the surfaces and the second 
node 2. slider (SURF Duplicates) includes the erroneous duplicate surfaces. For 
triangulation purposes only the correct input surfaces are needed.  

 Just RMB click on the duplicates and then use Edit > Delete 

command or  icon. 

 

The verification of surfaces is done through the Modify Surfaces > Verify 
Surfaces command.  

 Start the Modify Surfaces > Verify Surfaces command and press 
OK with the following (default) parameters: 

 

 

After a while you will see the following result:  
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The folder icon in front of the slider component is red. This, as well as the result 
dialog, points out that there are errors in the model. The slider model has gaps. 
To display these gaps  

 first erase the screen with the View > Hide All command and then 
click on the '+' box in front of the slider node. 

 After that select the 109. Errors element. The graphics area and the 
Model Tree should look as below: 

 

 

We can see that the end of the rod in the slider is open. Short visual investigation 
shows that the gap is flat and will be easily repaired after the triangulation with 
Fix Model > Repair Shells command which will be done later. 
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Triangulating the surface 

Now  

 Select the slider part again and 

 Triangulate the slider part with the Modify Surfaces > Triangulate 
command. 

The triangulation can only be done at the shell level and the program 
automatically proposes shell 1. slider (SURF Verify) as the target object if a 
surface or error gap leaf is selected. If this happens, press OK to accept it shell 
selection You will see the Modify Surfaces > Triangulate settings (if not all 
parameters shown, press Show Advanced button): 

 

 

 

These parameters control the accuracy and error repair options of the 
triangulation. The most important value is the Accuracy which gives the 
maximum distance of the triangles from the original surface model. See the On-
line Help Menus and commands/Modify Surfaces/Triangulate page and its 
settings for a detailed description of other parameters. 

Before continuing let's  

 change the STL auto-repair setting to Do not repair. 

We do not want to run the triangle repair automatically after the triangulation this 
time.  

 Press OK to start the triangulation. 

After a while you should see the following result on the display area and the 
Model Tree: 
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Inspecting the display and the Model Tree shows us the same gap as after the 
Modify Surfaces > Verify command. Also, some triangles are shown in pink and 
some triangles in blue color. The triangle outside is shown in pink and inside in 
blue the same way as it was with the surfaces. You may change the shading to 

temporarily to Shaded + Wireframe mode (  ) to see the individual triangles. 

 

Verifying triangulated models 

We will continue with triangle verification to check any errors in the triangulated 
model.  

 Give the command Fix Model > Verify Shells for the 2. slider (SURF 
Triangulate) component 

and you will see the Verify Shells settings dialog (if you do not see all the 
parameters, press Show Advanced button): 
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We want to know all the gaps and check for possible intersections in the 
triangulated model.  

 Please check that your settings are the same as in the picture 
above. 

Then press OK to start the processing. You should see the following result 

 

 

 

which reports us the same gaps as seen before. The drawing area will show you 
the properly oriented slider with gaps. The Tools Window with Fix Model Tab is 
opened if not already open.  
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A closer look at the Model Tree will 
show us the resulting Verified triangle 
surfaces. During the verification the 
model is subdivided into separate 
triangle surfaces according to the 
parameters given to the Fix Model > 
Verify Shells command. For more 
details please have a look at the On-line 
Help of the Verify Shells command. The 
resulting Model Tree component will 
have 265 Triangle surfaces and one 
Gaps element in the end of the 
component.  

 

 

The model outside is now displayed with pink color. This is due to the fact that 
the verification also orients the triangle normal consistently, as seen in the picture 
on the previous page. 

The surface subdivision of the verified (or repaired) model will allow us to use the 
different surfaces efficiently for subsequent repair work, if necessary. For 
example, separate surface can be extruded or cut against each other with Modify 
Faceted > Boolean command.   

 

Repairing triangulated model 

Now it is time to produce a solid STL model for 3D Printing. We could have done 
this immediately after the triangulation, but for educational purposes we 
performed the Verification of the triangle data first. 

 

Now you should have a look at the Help 
Text window in the Fix Model tab. The 
model status is given, as well as help on 
what command to run next to produce a 
correct model from the selected shell.   

 

 

 

 Start the command Fix Model > Repair Shells with the 2. slider (STL 
Verify) node. 
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You can also use the shortcut in the Fix Model Tab: 

 

The Repair Shells settings dialog will appear after the command is given: 

 

Again, we will Check for triangle errors in the data. Now we will also close gaps 
in the model. The Stitch gaps smaller than parameter gives the upper limit to sew 
together thin gaps between the surfaces (automatically calculated for each 
model). The Fill gaps smaller than parameter defines the maximum size for filling 
individual large gaps. Here we want to close All of them.  

 Make sure you have selected the parameters above and start the 
command by pressing OK. 

Note: The Advanced parameters are needed when you are working with models containing 
difficult errors. You can learn to work with difficult models by downloading the “STL and VRML 
repair examples” document and associated example files through the Help > Tutorial Documents 
command.  

The result will be a correct STL model. The display area shows a pink model 
without any gaps. This means that we only see the outsides of the triangles, i.e. 
all triangles are correctly oriented.  
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The Model Tree indicates a correct model with the green icon in front of node 2. 
slider (1. Repair). If you open the Model Tree and select individual surfaces, you 
will see that the surfaces are sorted by the surface area. The first Triangles 
surface is the largest and the last surface is the smallest. You can also use 
graphical selection to show individual surfaces by clicking on them with the left 
mouse button.  

The message and green icon in the Model Tree indicate that the shell is now 
correct and can be printed with a 3D Printer. Press OK to close the status dialog.   
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Lesson 11 – Preparing for simulation applications 

This lesson shows you how to use the Reduce and Refine commands in the 
Modify Faceted menu to reduce the number of triangles in an STL model as well 
as how to reshape the triangles for better aspect ratio. For some simulation 
software systems, it is important not to have too many triangles in the model to 
speed up the simulation. Some simulation applications require triangles with 
better aspect ratio to produce most reliable results.  

3Data Expert Reduction command can also be used for preprocessing data for 
Augmenter Reality (AR), Virtual Reality (VR) and game software systems. If 
required, the reduction will keep the textures and colors on the inputted VRML or 
ZPR model as accurate as possible after the reduction.  

Green box indicates if this lesson is applicable to given module: 

 View   Dimensions  Lite  3Data  Sim 

 

Starting the reduction 

Let's first  

 input the model Tutorials / GeomFiles / rava2.stl using the File > 
Open command. 

Accept the proposed units and when the Operation Mode must be chosen,  

 run the basic Auto Repair process on the model by pressing the Fix 
Model button in the Operation Mode Window 

 After a while you will have a correct model: 

 

 

 



Expert Series 12.1: Tutorial 1 – Working with 3D Models  

 Page 112 

Now select the rava2 (Verified) in the Model Tree and  

 give the command Modify Faceted > Reduce. 

Reduce parameter dialog will appear: 

 

There are three different main reduction methods and you can affect the result by 
selecting the most suitable method for your application: 

 Minimum edge length method will allow you to set the minimum edge 
length to be left in the model, all triangle edges shorter than the given 
minimum edge length are removed.  

 Maximum number of triangles method will remove triangles until the 
number of triangles reaches the given maximum triangle count.  

 Maximum deviation from the original surface will remove all triangle 
edges which do not cause the surface points to move more than the given 
maximum deviation.  

Whichever method is used, the triangles are reduced so that the given limits are 
respected. Anyhow, the command does not reduce triangles so that erroneous 
geometry would be generated (i.e. non-manifold geometry with more than two 
triangles at an edge, overlapping triangles etc.).  

The limits for the reduction method are given in the Main filters group. Each 
reduction method has its own Main filter which must be used with the method. 
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 Edge length filter will set the minimum edge length remaining in the 
reduced model for Minimum edge length method.  Maximum length 
multiplier sets the upper limit to the edge length change during the 
reduction, this is important when producing triangles for simulation 
applications requiring better triangle aspect ratio. Note: With Minimum 
edge length method you can use Surface deviation filter in addition to 
the basic Edge length filter to have even more control over the surface 
shape change.  

 Number of triangles filter will give the maximum triangle count left in 
the model after the reduction.  

 Surface deviation filter will give the maximum distance of the reduced 
surface from the original surface with the maximum deviation limit. 

Geometry feature filters will add special rules to preserve the geometric 
features in the model, i.e. the surface edges and triangle normal directions.  

 If Keep surface edges is set, the surface edges generated during the 
Auto Repair, Verify Shells or Repair Shells commands will be respected 
and not deleted from the model. Triangles can be reduced along the 
edges but not over the edges, effectively preserving at least a few 
triangles from each surface in the model. Also, sharp corners at open 
edges (at the gap curves) are preserved with the user defined limit, all 
corners shaper than the given limit are kept. For example, a square with 
90 degrees sharp corners will remain a square after the reduction with the 
default 135 degrees sharp open edge angle limit (90 < 135).  

 Triangle normal direction change will limit the change of triangle normal 
to the given degree value. This will very effectively prevent large changes 
in the model shape. For example, if a cylindrical hole needs to be reduced 
to minimum number of triangles (i.e. a triangle shaped hole), you must 
increase the maximum change angle to 45 degrees or more, by default 
only 10 degrees changes are allowed and thus cylindrical holes may 
remain densely triangulated.   

Color and texture feature filters will add special rules to preserve the textures 
and colors in the model. These rules are similar to the rules applied to the 
surface edges above, i.e. triangles are not reduced over texture or color 
boundaries, but they may be reduced along a texture boundary. This will always 
leave a reduced representation of the texture (or color) area in the reduction 
result. Color and texture feature filters are useful when reducing data for 
Augmented Reality, Virtual Reality or game applications. Sharp texture edge 
angle and sharp color edge angle work in the same fashion as sharp open 
edge angle above.  

Generally, the more filters you are using, the less reduction may happen and the 
longer it may take to run the command. On the other hand, filters are very 
important for preserving desired features in the model.  
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Reducing rava2 model 

Now let’s try to reduce the rava2 model with the default parameters. You can 
make sure the default parameters are in use by  

 pressing the Default button in the dialog. 

 Then press OK button.  

You will soon see the result with 71% reduction: 

 

If you compare a detail in the original model (left hand image) with the reduced 
model (right hand image below), you can see that the geometric features are 
very well kept while a serious reduction is applied to the model.  
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There model still looks the same but now there are only 1628 triangles left from 
the original 5674 triangles. 

Generally, there are no edges shorter than 1.0 units left in the model anymore. 
The new edges originally shorter than 1.0 units are now between 1.0 and 2.0 
units (1.0*upper limit multiplier = 2.0).  

Let's try another reduction with 2.0 minimum edge length.  

 Press Edit -> Undo Reduce and then 

 Modify Faceted -> Reduce again and set the minimum edge length as 
seen below:  

 

Then  

 press OK 

and after a short while you will see the result:  

 



Expert Series 12.1: Tutorial 1 – Working with 3D Models  

 Page 116 

You can clearly see how more triangles are reduced from the mesh and still the 
model shape remains accurate.  

There are some areas where you can still find triangles with shorter edges than 
2.0 mm's, as seen in the image below:  

 

 

These areas are due to small one triangle surfaces in the original model (in green 
bounding box above), Keep surface edges filter prevents us from deleting any 
surfaces fully from the model. To remove minor surfaces like this we can make 
another run with the minimum edge length 2.0 units but  

 turn Off the Keep surface edges filter, as seen below: 

 

 press OK to rerun the Reduction. 

 

This will produce another 18% reduction by removing some small surfaces 
altogether.  
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Let's now try the other reduction methods.  

 Press Edit > Undo until you have the original rava2 (Verified) model 
available again (here in shaded + wireframe display mode). 

 

 

Then  

 give the Modify Faceted > Reduce command 

 press the Default button and give the following parameters  

 reduce to maximum 1000 triangles:  
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 Press OK to see the following result with 82% reduction and 1000 
triangles: 

 

 

 

There is still one method to go, Maximum deviation from the original surface. 

 Give Undo command, then 

 start Reduce and give the following parameters after pressing 
Default button:  
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Now the maximum allowed distance of the resulting surface is 1 mm from the 
original surface.  

 Press OK and you will end up with 928 triangles: 

 

Which reduction method to use? 

As you can see there are different ways to get to reduced result, depending on 
the requirements set to the end result. Generally, Minimum edge length method 
should be used if a reduced triangulation with evenly shaped triangles is 
required. Maximum number of triangles method should be used if there is 
some definite upper limit to the triangles accepted for the receiving application. 
Maximum deviation from the original surface should be used if keeping the 
model shape is the most important requirement. Some simulation systems as 
well as 3D printing applications may require that.  

 



Expert Series 12.1: Tutorial 1 – Working with 3D Models  

 Page 120 

Improving the triangle aspect ratio 

Triangle reduction command can also be used to create triangle mesh with a 
better aspect ratio, i.e. to remove very thin triangles from the mesh. This is an 
important feature for some simulation applications, better shaped triangles will 
generate more accurate simulation results. Better aspect ratio is achieved by 
combined use of the Modify Faceted > Refine and Reduce commands.  

We will start this exercise by  

 reopening the rava2.stl file and 

 running the Auto Repair on it through the Operation Mode Fix Model 
button. Then repeat the first reduction done in the chapter Reducing 
rava2 model (i.e. press Defaults button) 

 Select the 1. rava2 (Verified) shell in the Model Tree,  

 give the command Modify Faceted > Reduce and press Default 
button in the Reduce parameter dialog.  

 The press OK to get the first reduce result:  

 

 

We have now removed excess triangles from the mesh. Next we will run the 
Refine command to generate new triangle corner points into the mesh. These 
new points will be used to create new evenly shaped triangles during the next run 
to the reduction.  

First you should estimate the minimum size of the triangles you would like to see 
in the resulting mesh. Let's assume we want to use approximately 1.0 mm 
triangle size. In this case we will first refine the mesh to maximum 1.1 mm edges 
and then reduce it to 1.0 mm edges to get to the desired result.  

 Select the rava2 (Reduced) shell from the Model Tree.  
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 Give the command Modify Faceted > Refine, then fill in the following 
parameters: 

 

 Press OK to start the Refine command, after a while you will see the 
following result on the screen (next page). 

The result now contains approximately 172 000 triangles. It is full of very thin 
triangles with bad aspect ratios. Anyhow, now we have a suitable set of new 
triangle corner points available for the reduction to generate new evenly shaped 
triangulation.  

 

The refine result does not contain surface information in it. To be able to produce 
more accurate reduction results with the Keeps surface edge filter we must 
regenerate the surface edge information to the model. To do this you should 

 

 

 run the Fix Model > Repair Shells command with the following 
default parameters: 
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 After 

 pressing OK you will see the shell subdivided to surfaces again: 

 

Now we are ready to simply  

 run the Reduce command on the rava2 shell with the Default 
parameters. 
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After a while you will have the result with 78% reduction. The result will contain 
approximately 37 000 triangles.  

 

If you look closer, the triangle mesh is well shaped all over the model ensuring 
accurate simulation results: 

 

If you wish to get even less triangles but to keep the good aspect ratios, just 
rerun the Reduce command with a bigger minimum edge length value. For 
example, value 5.0 gives the following result with approximately 2300 triangles:  
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For the last reduction, you would achieve optimal results if you would use Edge 
length value 5.5 mms in the first Refine but this example shows that you can use 
very strong Edge reduction on any kind of model and still get good results for 
simulation applications.  
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Conclusions 

Thank you for going through these Tutorial lessons for Expert Series software. 
You can now use the Expert Series software modules for everyday 3D printing 
work or prepare surface and STL data for simulation software packages.  

The Expert Series software contains a vast number of features not covered in 
this document. Please refer to the On-line Help and its examples for more 
information on the available functionality.  

To learn more about the use of the STL and VRML handling available in the 
Expert Series software, please have a look at the advanced repair document: 
Expert Series 12.0: STL and VRML repair examples. This document is available 
through the Help > Tutorial Documents command and the demo files are stored 
in the Tutorials / GeomFiles directory under the software installation directory.  

We hope you will have a productive time with the DeskArtes Expert Series 
software in your everyday data preparation work. If you have any questions or 
comments on the use of the DeskArtes software products or this manual, do not 
hesitate to contact us at support@deskartes.com. 
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