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Foreword 

The 3Data Expert 12.1: Tutorial 3 - Separating Shells document provides a few 
simple examples on how to separate areas in a shell into separate shells for 
different material or color definitions. The separated shells can be used to 
produce 3D printed parts with multiple materials (= different shore values) or with 
different material colors in different areas.  

First, this document describes the use of special and easy to use Print 
Preparation > Separate to Shell commands for separating model surface areas 
into new shells. There are three different separation commands available: Offset 
to Shell, Extrude to Shell and Fill to Shell commands. Accompanied with Fix 
Model > Clean Surfaces command the shell separation is possible with just a few 
mouse clicks. The time requirement for these examples (Chapters 1 to 5) is 
about 10 minutes.  

The document also describes the use of normal Cut Tool and Hole Tool 
commands for separating shells by cutting the model. Extrude from surfaces and 
Offset commands are used to generate solid shells from selected surface areas. 
The use of Triangle Edit and Sketch Edge Line commands to define new 
surfaces areas for shell separation are also described. The time requirement for 
these examples is about 20 minutes.  

If you are a newcomer with 3Data Expert, we recommend you to go through the 
3Data Expert Quick Start Guide available through Help > Tutorial Documents 
menu to learn basic visualization and selection commands with the software 
before going through this document. Also, Split command can be used for 
separating shells by splitting the model, as explained in the Quick Start Guide. 

Full tutorial set for Expert Series contains several documents which cover 
different aspects of model repair, coloring and print preparation. The tutorials are 
available in the software distribution package through the Help > Tutorial 
Documents menu:  

 Expert Series 12.1: Quick Start Guide gives a short introduction to model 
repair and splitting for 3D Printing with 3Data Expert, 3Data Expert Lite 
and Dimensions Expert products. Estimated completion time 15 minutes. 

 Expert Series 12.1: Tutorial 1 – Working with 3D Models introduces basic 
viewing, measuring, automatic repair, split, connect, hollow, offset, 3D 
Text, Boolean, cut, reduce, 3D nesting, surface triangulation and other 
model manipulation functions available for STL files. Applies to All Expert 
Series modules. Estimated completion time is 3 hours.  

 3Data Expert 12.1: Tutorial 2 – Working with Colors introduces basic 
automatic repair and coloring for 3D Color Printer users. For 3Data Expert, 
3Data Expert Lite and 3DEdit Pro. Estimated completion time is 1 hour.  
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 3Data Expert 12.1: Tutorial 3 – Separating Shells describes the use of 
Shell Separation commands in 3Data Expert. These commands enable 
separating a part into several shells for different material (shore value) or 
color definitions in a single part. For 3Data Expert only. Estimated 
completion time is 30 minutes.  

 3Data Expert 12.1: Tutorial 4 – Generating Supports for AM explains the 
use of new Generic Supports command and Sand Supports command. 
The support generator can be used to generate supports for DLP, metal, 
stereolithography and sand based processes. Adding extra connectors to 
prevent parts from warping and bending during the build is explained. 
Also, new slicing, slice preview and slice filling is demonstrated. Estimated 
completion time 1 hour.  

 Expert Series 12.1: STL and VRML repair examples document includes 
more advanced model repair operations with 3Data Expert. Applies to 
3Data Expert module and mostly to 3Data Expert Lite, Dimensions Expert 
and Sim Expert modules. Estimated completion time with 3Data Expert 2 
hours.  

The tutorial documents and the geometry files for the tutorial examples are found 
in the Tutorials folder and its sub-folders (GeomFiles, Tutorial 1, Tutorial 2, etc.) 
in the 3Data Expert (or product in question) installation directory.  

This document uses cellphone-repaired.3de model as an example. The file 
comes with the 3Data Expert installation in the tuorial / GeomFiles directory.  
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Chapter 1 – Preparing for shell separation 

Shell Separation commands allow you to separate surface areas and other 
components from a repaired shell into separate shells. The separate shells will 
lay exactly on top of the part they are separated from and they can be used for 
defining different material properties (shore value) or different colors in a single 
part.  

In the sequel we will first prepare a file with low quality surfaces for shell 
separation operation. Of course, this is most of the time not needed, but shows 
how to work on low quality data too.  

 

Input cellphone.3de 

First open the tutorials > Geom Files > cellphone-repaired.3de file with the 
File > Open command. Accept the proposed units (inch) 

 

and close the Operation Mode dialog by pressing the close box in the upper right 
corner of the dialog or press Print Preparation icon. The model is already fixed so 
we do not need to perform any fixing. 

 

 

After the input the cellphone model is visible on the graphics area: 
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The new shell generation commands are based on the surface subdivision of the 
triangle model. A set of surfaces is first selected and then a solid shell is created 
from them.  

Before we go on with the shell separation, let's check the surfaces on the 
cellphone model first. Now turn on the surface edge display with Colors and 
Texture > Edit Surfaces > Show Edge Lines command: 

 

You will immediately see the surface edges displayed with orange edge lines: 
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Closer investigation shows that there are excess amount of surfaces and surface 
edges. The surface edges have originated from the original input model which 
had several separate shells which were then stitched into one shell (as described 
in Tutorial 1 - Working with 3D Models document). 

For example, the largest cylinder fixture on the round end of the part is made of 
several surfaces, as seen in the image below: 

 

Because we want to separate surfaces on the cylinder into separate shells, lets 
simplify the surfaces subdivision first.  

The number of shells, surface, triangles etc. on the selected Model Tree object is 
always displayed below the Model Tree: 

 

 

Note: When you need more info on how to create new surfaces manually by adding edge lines on 
the model, please see 3Data Expert 10: Tutorial 2 – Working with Colors.  
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Chapter 2 – Simplifying with Cleaning Surfaces command 

The Clean Surfaces command is used to simplify surface subdivision on the part.  

 select first shell in the Model Tree 

 give command Fix Model > Clean Surfaces...  

 

A parameter dialog appears filled with default parameters: 

 

The parameters are automatically calculated based on the part size. This time we 
will just accept them and reduce the number of surfaces with default settings. 
The explanation to the parameters can be found in the Help pages.   

 Press OK to start the command 

After a while the surfaces are reduced into more meaningful set: 
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Now we can easily select the surfaces in the cylinder fixture for shell separation. 
Also, the total number of surfaces is reduced from > 600 to < 300, as see in the 
bottom of the Model Tree: 
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Chapter 3 – Using Offset to Shell command 

First we will use offset function to separate shells from the cellphone model. 
Offset to Shell command will offset all multi-selected surfaces and create new 
shells from them.  

First set on the Surface selection mode through the Selection mode buttons: 

 

Let's now select surfaces for shell separation: 

 rotate and zoom the view to see the surfaces to select 

 use graphical multi-selection (CTRL + left mouse button) to select the 
four (4) adjacent surfaces as seen in the image below 

 

 

 

 give command Print Preparation > Separate to Shell > Offset to Shell  
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After the command is given a parameter dialog is displayed with the default 
parameter values. Fill in the values given below (0.01 inch) and uncheck the 
use default check box: 

 

The given settings will produce a solid offset of the selected surfaces. The offset 
will be inside the mode (Back faces) and the thickness is 0.01 inch. Normally, 
you should use as small thickness as possible to avoid potential errors with the 
offsetting.  

 Now press OK to generate the separate shell from the selected 
surfaces. 

After a while you will see the result in the Model Tree. The original shell is now 
selected and stored as the last shell in the Model Tree and the separated smaller 
shell(s) is just in front of the original shell. Separated suffix is added to both 
shells.  
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For clarity, lets now rename the shells with names describing their material 
composition and to output them correctly to disk files later. We will rename the 
first shell (from the cylinder) as cyl-shore-50-1 and the original part with cell-
shore-20-1, as seen in the image below (shore value is used to describe the 
“rubberness” of a material):  

 

The 1. cyl-shore-50-1 shell is a fully separate solid shell laying on top of the 
original model with shrunk cylinder. The thickness of the shell is approximately 
0.01 inch and it follows accurately the cylinder left in the original model:  
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Chapter 4 – Using Extrude to Shell command 

Now we will use extrude function to separate shells from the cellphone model. 
Extrude to Shell command will extrude all multi-selected surfaces in a model and 
create new separated shells.  

First we will select suitable surfaces for shell separation in the model: 

 set Surface selection mode on 

 rotate and zoom to correct view point 

 use graphical multi-selection (CTRL + left mouse button) to select the 
tow long and thin surfaces going around the model as seen below 

 

 give command Print Preparation > Separate to Shell > Extrude to 
Shell 

 

After the command is given a parameter dialog is displayed with default 
parameter values. Fill in the values given below (thickness 0.01 inch), direction 
Avg. normal (average surface normal) and uncheck the use default check box: 
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Our goal is to create thin separate shell on top of the original model walls. 
Extrude to Shell can be used especially when separate shell is created by adding 
material on top of the original model.  

Note: Tapering is useful when extruding convex areas towards the inside the 
model to avoid surface intersections at the extrude area edges. Normally you 
should use Offset to Shell when separating shells towards the inside of a part, as 
seen in the previous example.  

When ready,  

 press OK to generate the new shell on top of the thin walls. 

After a while you will see the results in the Model Tree. The original shell is once 
again the last shell in the Model Tree and the two new shells just in front of the 
original last shell. Separated postfix is added to all resulting shells.  

 



3Data Expert 12.1: Tutorial 3 - Separating Shells 

 Page 16 

Rename the new shells with unique names, edge-shore-50-1 and edge-shore-
50-2 as seen in the image below:  
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Chapter 5 – Using Fill to Shell command 

The final special shell separation command is the Fill to Shell command. This 
command will separate and fill all multi-selected surface set and create new 
separated solid shells.  

The Fill to Shell command is best applied to a set of surfaces which create a 
nearly closed volume or where the gaps created at the separation can be filled 
with normal gap fill. For example, the four small fixtures in the cellphone model 
meet this criterion. One suitable fixture is circled below:  

 

Now let’s separate the surfaces making the fixture into a separate shell: 

 set Surface Selection mode on 

 use graphical selection to select the surfaces show in the image below 
(Ctrl + LMB or Alt + LMB for rubberband selection) 
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 give command Print Preparation > Separate to Shell > Fill to Shell 

 

After a while you will see the fixture separated and the solid result in the Model 
Tree. The last shell in the Model Tree will be the original part and the shell before 
that is the small separated fixture: 

 

 

Rename the fixture with a suitable unique name (fixture-shore-50-1) for output 
later: 
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Outputting separate STL files 

To finish the shell separation process we want to output the shells into separate 
STL files. We have already named each shell with a unique name which will be 
used for the disk file names too, as seen in the image below: 

 

 

To output the files 

 select Model Tree root All 

 give command File > Save As... 

 make sure .stl file type is selected 
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 press Properties (circled in green below) button in the Save As dialog 

 select Separate files (circled in yellow below) setting in the STL Output 
Options dialog 

 

 

 

 press OK in the STL Output Options dialog 

 press Save in the Save As dialog 

 

If you get a following dialog complaining the permission to save, press Yes and 
select a folder where your user account has write access. 
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Then a query dialog appears: 

 

 

 press Yes to use the shell names for file names during the output 

The shells are written in separate disk files with the shell names. These files can 
be inputted to receiving 3D printing system for different color or material settings.  
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Chapter 6 – Using Cut Tool to separate shells 

The easiest and most recommended way to generate separate shells from a part 
is described in Chapters 1 to 5. In this and following chapters we will take a look 
at some other efficient but not so straightforward methods to create separate 
shells from a connected model.  

One efficient way to generate separate shells from a solid shell is to use Modify 
Faceted > Cut Tool command. This Chapter shows you how to use Cut Tool 
command available with 3Data Expert for separating model areas into separate 
shells.  

First open the cellphone-repaired.3de file with the File > Open command. 
Accept the proposed units (inch) and close the Operation Mode dialog by 
pressing the close box in the upper right corner of the dialog. The model is 
already fixed so we do not need to perform any fixing. 

We will first separate the largest fixture in the round end of the cellphone model: 

 

Separating the largest fixture 

To separate the fixture, start with the following commands: 

 take a view from the Z axis direction 

 select the 1. cellphone (Repaired) shell from the Model Tree 

 give command Modify Faceted > Cut Tool, a Cut Tool dialog appears 

 make sure Draw surfaces selection is set in Create cutter with group 
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 select Curve type in Draw cutter with group because now we want to 
draw a smooth curve around the separated area instead of a polygon 

 

 

 

Then we continue to draw the separated area: 

 zoom closer to the model, if necessary 

 press New cutter button to start inputting curve around the fixture 

 continue adding curve points with the crosshair icon evenly around the 
fixture so that the curve does not overlap the vertical walls of the fixture 

 when ready, close the curve by picking the first point again with the 
crosshair icon 

 you may select and move the curve points with LMB (left mouse 
button) so that the curve is evenly around the fixture 
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Now the curve is drawn correctly around the fixture. To finish the cut tool 
generation 

 press RMB (left mouse button) to finish the curve edit 

 the cutter 1 tool appears in the Cutter surfaces list and Model Tree and 
is displayed on the graphics area (rotate the view to see it) 

 

 

 

Now we will tune the cut tool to correct depth: 

 select the cutter 1 in the Cutter surfaces list, this will allow us to fine tune 
the tool depth 

 select Slider selection in the Cutter surface extents group 

 open Clipping Tab by pressing    icon 

 use Y clip plane to see the cut tool to go through the whole model 
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Now you can set the correct depth for the cut tool. We do not want to go through 
the whole model, we only want to separate a shell with sufficient contact to the 
original part: 

 start moving the slider in the Cutter surface extents group 

 you will see a bounding box with the maximum extent of the cut tool 
displayed 

 move the left end of the slider towards the right end with LMB 

 the bottom plane for the cut tool is displayed in the bounding box and the 
tool is cut accordingly, please see on the image next page. 
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Fine tune the cut tool depth: 

 move the slide left end until the cut tool bottom is somewhere in the 
middle of the cellphone model, as seen in the image below. The cut tool 
must be fully intersected by the surfaces in the cellphone body: 

 

 

Now we are ready to select the correct operation and to apply the cut tool: 

 select Separate operation in the Cut operation group 

 press Cut button to apply the Separate operation 

 



3Data Expert 12.1: Tutorial 3 - Separating Shells 

 Page 27 

 

 

 

Soon you will see the cut fixture on the graphics area: 
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And the cellphone body has corresponding hole: 

 

 

You may need to run Fix Model > Repair to the body to get rid of minor gap 
generated to the body during Boolean operation topology generation. Finally, you 
will have the two separate shells available for different sore value definitions. 
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Renaming shells and outputting STL files 

You may select and store each shell into a separate STL file just by selecting 
them in the Model Tree one by one, giving File Save As command and defining 
suitable file name during the file save.  

You can also output each shell into separate STL file with one command and in 
more controlled fashion. For example, the following process would allow you to 
plan and indicate the correct shore value for each shell before output: 

 rename the two shells through RMB menu on the Model Tree with 
indication on the desired shore value, a-cellphone-s50 and b-cellphone-
s20, for example. You must make sure that all shell names are different.  

 

 

 give Edit > File Save As command 

 select Save as type: STL 

 select All shells for output 
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 select Filename from Default 

 press Properties button for STL Output Options, select Separate 
files 

 press OK to close the output options 

 

 

 

 press Save to start file write, a question box appears 
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 press Yes to use the shell names for file names 

 

And you are ready, the files with names b-cellphone-s20.stl and a-cellphone-
s50.stl are stored on the hard disk.  

 

Emulating material properties with colors 

You can actually emulate the final print result by setting different colors to the 
shells using the Color and Texture tab commands. Please see Tutorial 2 – 
Working with Colors for more details on painting objects. Colors can be seen 

when the 3D Color Printer mode is set through   icon (Note: only colors are 

available, transparency cannot be defined).  
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More cutting planes 

Cut Tool allows you to define any number of cutter planes and they do not need 
to be closed tubes as was used in the example above. You just need to make 
sure cutter planes are drawn in consistent order for consistent inside/outside 
separation, please see more at Help pages for Cut Tool command. Generally, 
the inputted points for different cut planes should be given either in clockwise or 
counter clockwise order around the middle of the area to be separated.  

Multiple cutter planes can be used to separate geometries in very complicated 
topologies accurately, like in medical models:  

 

 

 

Using Hole Tool to separate small flat surface areas 

The Modify Faceted > Hole Tool command can also be used to separate simple 
areas from a solid STL model. It works in similar fashion as Cut Tool command, 
you first define a tool to apply on the model and then separate the desired area. 
With Hole Tool you can only create circular (smooth or polygon) tools on top of 
the surfaces.  

In the image below we have generated and tuned a circular area on the other 
side of the cellphone model for separation:  
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When the depth for the separated round area is correct, select the correct 
operation parameters (Delete and Create cap) and press Create button: 
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After a while you will have a round are separated into a new shell: 

 

 

In case of errors in one of the separated shells, please run Fix Model > Repair 
Shells command on error shells (1. a-cellphone (Cut)) to get fully correct 
components.  
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Chapter 7 – Using Extrude to separate shells 

This Chapter shows you how to use Fix Model > Edit Triangles to create new 
surfaces for shell separation with Create Geometry > Extrude Surface > from 
Surface command.  

Creating surfaces with Edit Triangles command 

Edit Triangles command allows you to select any triangles and separate them 
into a new surface for Offset or Extrude command. We will use the same 
cellphone-repaired model for this example too.  

Start by: 

 input the cellphone-repaired.3de model, continue through the units and 
Operation Mode dialogs 

 take a view from -Z direction (bottom) 

 select Model Tree root All 

 give Fix Model > Edit Triangles command 

 use LMB to select desired triangles from the model, as seen below, 
grayed 

 

 

When you have selected the triangles, it is time to separate them into a new 
shell. We have the Model Tree All selected, this causes the separated triangles 
to be stored automatically into a new shell: 
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 press the    icon to create new shell for the triangles 

 

A new shell is created in the Model Tree, 2. Separated triangles. Also, gaps 
shown on the graphical area indicate that the two shells are no longer solid.  

 

 and then press Close button to end Edit Triangles 

 

Using Extrude from Surfaces command 

Extrude from Surfaces command can be used to extrude surfaces from solid 
shells or flat/open shells. We can either select the 2. Separated shell or the 
surface in it for the extrude command. Let's do the following: 

 select the 1. Triangles surface in the 2. shell 

 give Create Geometry > Extrude Surface > from Surface command 

 fill in parameters as seen in the image next page (Direction Opposite and 
thickness 0.01 inch) 
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We will generate an extrude towards the inside of the original model (Opposite) 
and with 0.01 inch thickness.  

 press OK to create the extrude 

 

The result is a solid shell with given thickness.  

The original cellphone shell is still open and missing the corresponding blind hole 
on the surface. We now need to move the new surface generated by the Extrude 
command from the 2. shell into the 1. shell.  
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Copying Extruded surfaces to original shell 

We will select all surfaces generated by Extrude and copy them into the original 
shell to make it solid again: 

 select all surfaces except the original surface taken from the cellphone 
model 

 

 give Edit > Copy command 

 select the 1. cellphone shell from the Model Tree 
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 give Edit > Paste command 

 and you will have a correct 1. shell in the model tree too 

 hide the 2. Separated triangl shell to see the corresponding blind hole 
on the cellphone surface 

 

 

You can now rename and output the shells into separate STL files as was done 
in the chapter Renaming shells and outputting STL files (see page 29). 
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Chapter 8 – Using Offset to separate shells 

In a similar way as Extrude command, the Print Preparation > Offset command 
can also be used to generate solid shells from separated surface areas. In this 
example we will first separate a surface area with Sketch Edge Line command 
and then separate and Offset it to solid shell.  

 

Creating surfaces with Sketch Edge Line command 

Let's start again with cellphone-repaired.3de model: 

 input the cellphone-repaired.3de model, continue through the units and 
Operation Mode dialogs 

 take a view from -Z direction (bottom) 

 select 1. cellphone (Repaired) shell from the Model Tree 

 give Color and Texture > Edit Surfaces > Sketch Edge Line command, 
the system goes into curve input mode and surface edges are displayed: 

 

The system now waits for you to draw the new surface edge on the model: 

 add points on the model using the LMB 

 to quit adding points select the first point again, i.e. create a closed 
curve, as seen on the image below 

 you may select and reposition the points until the curve shape is 
correct 
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Now our surface edge line is ready and we will generate the new surface on top 
of the cellphone model.  

 press RMB to add the new surface on the model 

 run Fix Model > Repair Shells to fix minor errors in the model (and to 
avoid seeing hidden surface edges) 

 and you will see the new surface: 
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Separating the sketched surface 

The new surface must be separated to a new shell before it can be Offset to solid 
model.  

 select the sketched surface from the graphical area or from the Model 
Tree 

 

 give Edit > Cut command 

 select Model Tree root All 

 give Edit > Paste command 

 turn off surface edge line display via Color & Texture > Edit Surfaces > 
Show Edge Lines setting.  
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The Model Tree now contains two shells, one with the original cellphone mode 
without the delete sketched surface and the sketched surface in shell 2. Copy 1 
of cellphone (Repaired) shell.  

 

Using Offset command 

We are now ready to use the Offset to generate the components for the new 
shells.  

 select 2. Copy 1 of cellphone shell from the Model Tree 

 give Print Preparation > Offset command 

 if you get a warning about the model not being fully repaired press Yes to 
continue 

 

 fill in the parameters given in the image below, especially Result into 
original shell must not be set! 
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 press OK to create the offset 

 fit the Offset result 3. Copy 1. of cellphone (Offset) to see the result 

 

You now have all necessary parts in the Model Tree for creating the tow solid 
shells. Do the following: 

 select the third shell 3. Copy 1 of cellphone (Offset) in the Model Tree 
(offset result) 

 give Edit > Copy command 

 select the 1. Repaired surface of the first shell 1. Cellphone (Repaired) 
in the Model Tree (original model) 
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 give Edit > Paste command to add the copied Offset result to the shell 

 you will see a correct 1. shell to appear in the Model Tree. The original 
shell now has the blind hole added to it. 

 

In case of errors in 1. cellphone (Repaired), please run Fix Model > Repair 
Shells command with default parameters on that, to get fully correct component. 
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Now we need to join the two remaining red shells in the Model Tree into one shell 
to get correct solid shell. For example: 

 select the Copy 1 of cellphone (Offset) shell 

 give Edit > Cut command 

 

 

 select the first surface in the Copy 1 of cellphone (Repaired) shell 

 give Edit > Paste command to paste the cut shell into the that shell 

 

 

In case of errors in 1. Copy 1 of cellphone (Repaired), please run Fix Model > 
Repair Shells command with default parameters on that, to get fully correct 
component. 
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Now you will have the two solid shells in the Model Tree for output, please see 
chapter Renaming shells and outputting STL files at page 11. 

 

 

 

Selecting multiple surfaces for Offset or Extrude 

Of course, it is possible to use the existing surfaces for separation and 
subsequent Offset or Extrude. For example, you may want to try to separate the 
surfaces around the keypad for separate shell creation.  

First select the surfaces show in the image below (Ctrl + LMB): 
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Then Cut and Paste them into Model Tree: 

 

 

Now you can use Offset to inside direction again (Opposite direction, result not in 
the same shell as the offset shell): 
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Then make the two shells solid again by Copying the Offset result to the original 
shell and then connect the separated shell and the offset shell into a solid shell: 

 

There are some errors in the generated shells, run them both through the Fix 
Model > Repair Shells command. The separated parts turn out to be correct but 
there are still some errors in the original cellphone model: 
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The errors are caused by some zero volume walls and intersecting triangles in 
them. These are created when the Offset result is added to the original model. 
The Offset direction follows the vertical walls of the holes in the original model:  

 

The seriousness of these errors with different 3D printing systems is not known 
at the time of the writing, but must be taken into consideration when creating 
separate shells at areas where surfaces meet perpendicularly at the extrude area 
edges. This result is found in Tutorials\GeomFiles folder (cellphone-offset-
separated.3de file). These problems should be solved automatically when the 
implementation of Extrude to Shell and Offset to Shell commands is completed.  
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Conclusions  

This Separating Shells document has given you the skills to separate shells from 
a solid STL model for systems with digital material properties or capable to 
produce parts with multiple colors.  

 


